5

I am working on a SharePoint Enterprise Server 2013, and I have created a custom list. Then I try modifying the default content type for the custom list, so I try adding the built-in Document content type inside it. But it seems the Document content type is not available inside the content type list, as follows:

enter image description here

So can anyone advise on this please? Now I am following this approach, because the Custom list offers "Item-level" permission unlike the built-in Document library. So I was planning to create a custom list (which provides an "Item-Level permission" section), then to add the built-in Document content type inside it, so I will end up having a Document library which have an Item-Level permission section, but it seems this is not available.

  • You activate in list options "manage content type"? For default is disabled – Diego Hillesheim Aug 25 '16 at 14:47
  • @DiegoHillesheim yes of course i active manage content type,, otherwise i will not get the list of content type at all !! – john Gu Aug 25 '16 at 14:56
4

Document Content Types can not be added to custom lists.

Documents and Folders both can have Item-Level permissions within Document Libraries.

In SharePoint 2013, item-level permissions are managed through "Sharing" to grant individual permissions use the Share Option. To manage the currently assigned permissions (or just to view them) you can click on the link in the list of users the document is shared with:

enter image description here

This will open the Shared With Dialog where you can invite additional users or Click Advanced to manage permissions (you can reinherit permissions or adjust directly from this page just like you manage any other permissions):

enter image description here

  • ,, when i talk about item-level permission,, i mean the option which is available inside the Advance Setting for custom list (and other list templates such as tasks) as shown in this picture i.stack.imgur.com/AHUh2.png ... i do not mean the option to stop inheriting permission on item level.. – john Gu Aug 25 '16 at 14:58
  • Gotcha. SharePoint does not do this for documents (which you obviously know). In the past, I have used a drop off library with approval. Users only saw their own documents in draft state. Once they were approved they were moved to a document library where they did not have permissions to edit. It fit a specific situation and may not work for you but some combination of versioning and approval is probably as close as you're going to get (or attachments as Eric has suggested) without an event-receiver or workflow to apply item-level permissions workaround. – theChrisKent Aug 25 '16 at 15:14
  • thanks for your help,, but this is not what i am looking for.. – john Gu Aug 25 '16 at 15:21
4

You cannot add a document content type to a list, that is breaking the basic foundation of how SharePoint works, things are either a list item, or a file.

To achieve what you want (list based item level permissions), you'd need a custom list with the metadata you desire, and users will have to attach their file(s) to the list item.

  • so instead of uploading document,, they will be creating an item list (maybe with a Title field only) and attach the document to the item .... but i am still not sure if internally the attached documents will have the same item-level permission as their items ,, or users can still edit documents by navigating directly to the folder where the docuemnt is uploaded ... – john Gu Aug 25 '16 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.