0

I am trying to create a new Web Application and Migrate my site from Dev to Prod. I keep on get the same error as below.

Even if I try and create a new site collection all the web parts are not working. Please help.

DelegateControl: Exception thrown while building custom control 'Microsoft.SharePoint.SPControlElement': Microsoft.SharePoint.WebPartPages.WebPartPageUserException: This page has encountered a critical error. Contact your system administrator if this problem persists.
at Microsoft.SharePoint.ApplicationRuntime.SafeControls.IsSafeControl(Boolean isAppWeb, Type type, String& unsafeErrorMessage)
at Microsoft.SharePoint.Utilities.SPUtility.CreateServerControlFromAssembly(String sControlAssembly, String sControlClass)
at Microsoft.SharePoint.SPControlElement.BuildCustomControl(TemplateControl tctlPage, String sControlAssembly, String sControlClass, String sControlSrc, XmlNode xnElementDefinition, SPFeatureDefinition featdefElement, String sElementId)
at Microsoft.SharePoint.SPControlElement.BuildCustomControl(TemplateControl tctlPage)
at Microsoft.SharePoint.WebControls.DelegateControl.BuildCustomControlResilient(SPControlElement ctlelemDefinition)

  • are you using any custom solution in Dev, if yes are they deployed in production? what method you are using for migration? – Waqas Sarwar MVP Aug 25 '16 at 12:55
  • SQL Server Backup and Restore – Ed Charles Diesel Sep 6 '16 at 12:37
  • what about the custom solutions or web part? – Waqas Sarwar MVP Sep 6 '16 at 12:46
  • None for Now everything it already on the farm I just need to activate them should I need them – Ed Charles Diesel Sep 6 '16 at 13:27
  • you should deploy and enable it, as from error you can see it is looking for the solution. – Waqas Sarwar MVP Sep 6 '16 at 13:28
0

Looks like you have a custom solution which is either not deployed or not activated. Site is looking for the solutions/webpart.

Please deploy and activate it so that page can render properly. But if you dont want to use that in your site still you need to activate first then remove it from your site collection.

If it is a webpart then you can try to disable the webpart on the page by browser this url" http://sitecollection url/default.aspx?Contents=1. You will see all the webparts and try to close the custom and retry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.