1

Requirement Criteria

I have SharePoint 2013 on premise. I have an excel sheet which loads data from the SharePoint list using listdata.svc service. I am able to load the data into the excel sheet successfully.

Now I want to show the excel sheet in the SharePoint page using Excel Web Access WebPart. So, I uploaded the excel sheet in the document library and referred the location of the file in the web access web part.

The data is shown first when I click OK button after configuring the web part but when I refresh the connection to show real data from the list it gives me an error: We couldn’t load the Data Model. This may be because the Data Model in this workbook is damaged.

Configuration of excel service application

I have given the Farm Administrator's credentials in the secured stored service application ID and referenced it in the Use an existing Unattended Service Account in the Global Settings of the Excel Service Application.

What am I missing to make it working? As the data should be reflected in the excel sheet if any changes are made to the list.

--Update--

If I give the Unattended Service Account name in the connection's Authentication Settings.. > Use a stored account property in the excel workbook I get following error when refreshing the data connection from the browser:

An error occurred while accessing application id Excel Services Application Unattended Service Account from Secure Store Service. The following connections failed to refresh: [Connection Name]

But if I select Refresh All option from the Excel client application it updates the data successfully in the worksheet.

  • Have you tried different browsers? Does the error occur on devices with another setups/OS/logged in user? – moe Aug 24 '16 at 6:53
  • Thanks for suggestion. I tried in Chrome and IE and it's not working.!! – users1100 Aug 24 '16 at 6:57
  • Are you using an AD account as the unattended service account for the connection? – moe Aug 24 '16 at 7:38
  • Yes. It's the AD account. – users1100 Aug 24 '16 at 8:02
  • I'd say it has to be a permission issue then. Ensure the SQL and CA configurations mentioned in various step-by-step guides – moe Aug 24 '16 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.