1

We have a three tier server farm with a one way trust with the WFE on the resource domain. I installed FBA and FBAPack. Everything is working fine and I can add domain users to sites if I'm adding them from the app server.

However, when I try to use the "Share" option on the web, I get the error: Sorry, we're having trouble reaching the server.

I originally thought it might be a problem with alternate access mappings, but doing research it looks like it might be a problem with the People Picker itself.

I ran the following commands multiple times on both app and WFE:

stsadm –o setapppassword -password password1!

stsadm -o setproperty -url http://server:port/ -pn peoplepicker-searchadforests -pv "domain:mydomain.com, mydomain\myadminuser, password1!"

But when I run stsadm -o getproperty -pn peoplepicker-onlysearchwithinsitecollection -url http://server:port

I get: Property Exist="Yes" Value="no"

The only thing I can think of is that the exclamation point is causing the issue. I read that the password needs to have no special characters. Unfortunately, this violates the password group policy.

Any ideas?

  • You missed some words in the post. You get what after you run getproperty? – Mark L Aug 24 '16 at 1:46
  • BTW, your steps are correct (I encountered same one-way trust issue before) but you may need to modify the permission on registry. Look at this. If it helps please let me know and I will make it an answer. – Mark L Aug 24 '16 at 1:50
  • Sorry, I think the formatting was treating the result like code. I edited, I get Property Exist="Yes" Value="no" Thanks for the article -- I was missing the Regedit on one of the servers. However, no change. I re-run commands and still get the error and the Property Exist result above. – Kevin Aug 24 '16 at 13:54
  • I should clarify just in case -- I did not change the registry on the database server but on the app server and the WFE. I can run it on the DB server also if necessary. – Kevin Aug 24 '16 at 14:01
  • Actually can't figure out how to change it on the DB server, the registry paths don't seem to line up. So I'm guessing that isn't necessary. – Kevin Aug 24 '16 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.