0

I have a single server farm, a SP Server 2010 migrated to SP server 2013. The current version is 15.0.4571.1502. I wanted to install the last CU but i get the error that an error occurred.

enter image description here

I found posts of people with the same problem, tried to solve mine as they did, but without success. I also tried to take the next CU after my version (April 2014 15.0.4605.1004), gives the same error. Tried to check the msi temp file in order to find something that would help me to figure out the problem, but nothing.

What can I do?

  • Should you check the event viewer , you might get some details about the issue , and please put it here if you find any thing useful – Mohamed El-Qassas MVP Aug 23 '16 at 13:32
  • I did it, but it's not easy to look for something you don't know. – Emaborsa Aug 23 '16 at 13:48
0

there are different reason for this error but you can try runt he CU via command line with bypassdetection of version number.

  1. Open the command prompt and browse to the folder where CU is save.
  2. Now Run the command like this sts2013-kb3114733-fullfile-x64-glb.exe PACKAGE.BYPASS.DETECTION.CHECK=1
  3. once it installed then run the config wizard.
  • Bypass the detection....is it safe? What problems may I encounter? – Emaborsa Aug 23 '16 at 13:50
  • i did in my production farm, it is safe rather it fix the problem for future. I would go with latest CU instead security fix. Reason,in our case was MSI file got deleted from the system folders – Waqas Sarwar MVP Aug 23 '16 at 14:07
  • I don't think to skip the version detection is the right way. If the system tells that something is not ok there must be a way to figure out what and why. – Emaborsa Aug 25 '16 at 6:56
  • Issue is there are some MSI and MSP files missing from Windows Installer folder which is causing the issue. why, i am not sure, may be somebody delete it? Now to fix, you can run the bypass thing which Hopefully install the missing MSPs and fix it for future. Or you can compare the installer folders with working server and install the missing one or you can rebuild the server. choices are yours. – Waqas Sarwar MVP Aug 25 '16 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.