2

I can able to change page layout for pages by editing the page. But for some pages 'Page Layout' option is disabled. I verified that Publishing feature is enabled and i have full permissions over site as well as on all pages, But still facing problem.

Please help.

1

You can only change the page layout for Publishing Pages and not Wiki pages. Are all of the pages you're facing issues with living in the Pages library that gets created when you activate publishing? Pages that live under "SitePages" would exhibit that behavior you are talking about with the layouts button being disabled.

  • yes all pages are publishing pages. – SP Developer Aug 23 '16 at 10:55
1

This can be an issue if you haven't updated your SharePoint Server 2013. In the early days you sometimes had to (1) reload the page or (2) navigate away and come back to the page or (3) log out and close the browser, open it again and try again.

Lately this issue has been solved AFAIK. So please check your patch status of SharePoint (Central Admin > System Settings > Manage servers in this farm) http://CentralAdminURL:port/_admin/FarmServers.aspx

Check the Configuration database version against SharePoint 2013 Build Numbers and see if you need to upgrade.

0

From the page you're experiencing issues with:

Go to Site Settings

Under "Look and Feel" go to Page layouts and site templates

Next to "Page Layouts" add any layouts from the left column by clicking the "Add" button. These layouts will become the ones that are available for users (or yourself) to change the page layout.

Click the OK button to save. Then, visit the page again (you might need to refresh the page or do a hard refresh (Ctrl + F5) ).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.