7

I recently applied OCT 2015 CU to my test environment, which consists of 1 App and 1 WFE server. After running the upgrade and restarting the servers, I tried to run the PS config through UI on the App server. It failed multiple times, but once i ran it through the Management Shell, everything was successful. However, when I checked the Upgrade status on servers it shows App server still needs upgrade whereas WFE doesn't require update.

What should i do to get rid of the Status? I even ran the PS config once again on App server which was successful.

9

This sometimes happens because the timer job CreateProductVersionJob didn't run as expected and you can try to restart the SharePoint timer service in services.msc.

If that doesn't do the trick, you run the PowerShell script Get-SPProduct -local. Even if it is a Get-script it does update the ConfigDB. It also forces the CreateProductVersionJob to start an update of the server registry.

You may need to run PSCONFIG again after this script, but this solves the mismatch problem in 95% of the cases I encounter this error. If not the account you're using doesn't have sufficient permission on the ConfigDB or isn't local admin on the server while upgrading.

Reference: SharePoint Patching and Get-SPProduct -local

If this don't help, you have to use more arguments in your psconfig script. I use this one which always work.

PSConfig.exe -cmd upgrade -inplace b2b -wait -force -cmd applicationcontent -install -cmd installfeatures -cmd secureresources 

Reference (my own blog): SP Nerd: An exception of type Microsoft.SharePoint.Administration.SPUpdatedConcurrencyException was thrown

  • after one day again the upgrade required started coming back. When I ran test-contentdatabase command I see there are some missing XML files from the directory which are deployed for specific web application and are missing from app server. Can I safely ignore this or should i retract all the solutions and redeploy them globally and rerun the psconfig. – Rakh Aug 25 '16 at 22:17
  • @Rakh Do you see the errors in the Health Analyzer? – Benny Skogberg Aug 27 '16 at 8:34
  • Sorry for the late response. I am seeing the same error in CA, ULS logs, event viewer. When I checked upgrade error log all I could see is missing features(XML files) from deployed custom solutions. These custom solutions were deployed on WFE and I could see all the XML files in that server but not in APP server. Not sure whether that is causing the upgrade failure – Rakh Aug 29 '16 at 18:57
  • @Rakh Missing feature doesn't effect the upgrade of SharePoint. But you can search for the error in this community and you'll find several good answers. – Benny Skogberg Aug 29 '16 at 19:24
5

this is known issue in sharepoint 2013 and 2016. You can safely ignore it. But if you want to get rid of this message then please run this run command.

psconfig -cmd -upgrade inplace b2b -force 

Hopefuly, Microsoft will fix this in upcoming CU.

  • Thank you waqar for your response. I am glad to know the information which you have provided above. I ran the command but ran into multiple errors without having much luck from log files. – Rakh Aug 22 '16 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.