2

I have a Pages library which also includes documents. We've made custom content types to attach some extra metadata. At the moment I've only got docx.

I've set the advanced permissions to Default open behavior for browser-enabled documents to Open in the client application. But it doesn't seem to be working in several different ways.

  1. In the list view from IE it does open in Word, but in Chrome it opens in the web browser.

  2. In search results from IE and Chrome it opens in the web app.

We have an on-prem installation of SP 2013 if that makes a difference. Our team doesn't own the installation so we have no access to central admin or anything like that.

I've found many posts about the web-app not working, but not many for this direction. I did find this reddit where they say that if SP can't detect that Office is installed it will always open in the web app. And that a fix is to repair office. We have thousands of users spread across the country. I don't think that is likely to happen. Is there a way to just turn off the web-applications for our site?

I could also go in and mess with the search result item template for office items, but I'm just wondering if there is a more simple fix.

I want MS Office documents to always open in the client application or to download, never to open in the web app.

  • are you checked web client service status , make sure that it's started on all WFE ? also are you want want MS Office documents to always open in the client application or to download, never to open in the web app for specific documnt library or all ? – Mohamed El-Qassas MVP Aug 19 '16 at 16:39
  • did you ever find a solution/workaround? – Tiago Duarte Mar 12 '18 at 9:31
  • Have not found a simple solution. Did modify the search result item templates and a few other things, but I couldn't really tell you where something is going to open. – Rothrock Mar 12 '18 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.