4

I have selected the option to return to the Classic UI for document libraries via the option that was available when viewing a document library. Now I want to switch back to the New Experience UI, how do I do that?

4

I also wondered further about the session cookie making the classic user experience and it was cookie named "splnu" with value 0. By removing it and pressing refresh button it switched back to setting by admin that was the new user experience.

For convenience it is good to use a kind of cookie manager extension in your browser - I used the cookie inspector for the google chrome (and available as tab) in the chrome developer tools and it was really a piece of cake :)

  • Excellent! This cookie tip fixed my issue, I could not go back to the Modern UI experience because of the site layout (Oslo). since the link to return to modern UI is under the quick launch, it was not possible to undo the classic view mode. – garfield185 Jan 16 '18 at 10:16
3

The name of the cookie is "spInu" with a value of 0. Deleting that one will restore the modern UI without having to clear all cookies.

2
  • In your document library, choose Settings icon and then Library settings.

enter image description here

  • Click Advanced settings and then scroll down to List experience.
  • Choose New experience.

enter image description here

For more details check Switch the default experience for lists or document libraries from new or classic

  • New experience has been released for library only. Am I right? – Atish Dipongkor - MVP Aug 19 '16 at 16:30
  • Dear @AtishDipongkor it's also for list , should you check the attached link where he mentions list or library but really I saw it for library only :) support.office.com/en-us/article/… – Mohamed El-Qassas MVP Aug 19 '16 at 16:34
  • I have checked the link. In my SharePoint Online site I did not see all new experiences. I can see SharePoint Home and Library experience only. – Atish Dipongkor - MVP Aug 19 '16 at 16:39
  • You are right my bro I also checked it and checked this article blogs.office.com/2016/06/07/… any way the questioner need it for library :) thanks for your precious time and valuable info , – Mohamed El-Qassas MVP Aug 19 '16 at 17:02
  • 2
    New experience for lists is in the process of rolling out to first release tenants – Eric Alexander Aug 19 '16 at 20:00
2

I found the answer to my question here http://answers.microsoft.com/en-us/msoffice/forum/msoffice_o365admin-mso_manage/how-to-switch-between-classic-and-new-library/b25035ec-21d0-4740-b7c7-1cf9ba3311bb.

The gist of this answer is that you must clear the browser cookie that indicates to use the new experience UI. The article states to clear all cookies, but I found I only needed to clear the cookies related to my SharePoint site. I was not able to figure out which cookie specifically needs to be cleared.

1

You can set the cookie directly without needing to clear them. Paste this into your URL bar while you're on the page:

javascript:document.cookie = "splnu = 1; path=/"

Then reload the page.

0

it is in the library settings under ADVANCED SETTINGS.

Look up for Library - library settings

£rd from top in the first column

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.