3

i am working on a sharepoint enterprise server 2013. and most of the lists i have been creating were based on the "Issue Tracking" list. since the issue tracking list provides a good starting point for me and it have a powerful ability to add comment and track them as follow:-

enter image description here

Today i was checking how creating a new list based on the built-in "Custom List" will look like.. i check different setting and i find an important section for the custom List named "Item-Level Permission" which is not provided inside the Issue tracking list:-

enter image description here

so can anyone adivce on these two points:-

  • why i did not get the same "Item Level permission" section when i created a new issue tracking list , same as the one i get when creating a new custom list?

  • as i mentioned before i uses the issue tracking list ,, because it provide a comment field which allow users to add comments on each version and also allow users to check previous versions of the item... so can i add such a column inside a new Custom list? . so in this case i can have the comment field + the item-level permission ??

Thanks

6
+100

Comment field with Append to Text

The Comments column in an Issues list uses the Append Changes to Existing Text setting. This setting is available for Multiple lines of text column types. Instructions for enabling the setting are below.

  1. Go to List Settings (or Library Settings).
  2. In the Columns section, click Create column.
  3. Name your column, and select Multiple lines of text.
  4. In the Additional Column Settings section, select Yes for Append Changes to Existing Text.

NOTE: Existing columns can have the feature enabled, but if the column has been in use, you may lose existing column data by enabling the setting.

Item-Level Permission Setting

The Item-Level Permissions setting is not available in Issues list templates. What is odd about this feature missing from the Issue template, is that every other major list type – Tasks, Discussion Board, Custom – all have the setting available in the Advanced Settings section.

Because so many other list templates provide the setting, I would think that a PowerShell script is floating around out there that would enable the feature. I did a cursory check on your behalf, but was unable to find any information. The only blogs I found outlined how to change item level permissions using a Designer workflow (using the Impersonator Step, and the following List Actions: Remove List Item Permissions and Replace List Item permissions), which is not what you are wanting to do.

6

To have BOTH assigned to emails and item-level permissions:

You can use a Tasks list and change the content type to Issues.

First create a list from the Tasks template. Go to List Setting >> Advanced Settings, select "Yes" for "Allow management of content types?" (Notice on that screen you have Item-level permissions, and e-mail notification.) Back at List Settings, click "Add from existing site content types" and select Issue. Remove the other content types by selecting them and clicking "Delete this content type." (Optionally, go back into advanced settings and change "Allow management of content types?" back to "No.")

Now your list will contain Issues, but also allow Item-Level permissions.

  • if i got your point correctly ,,, you want me to start with the Task template instead of the custom list template to get the " assigned to emails" ,, is this correct ? now in my case if i want to send emails to assigned to users ,, i think i will create a new workflow for this instead of relying on the default email template used... so i do not think it is a big deal... – john Gu Aug 25 '16 at 12:41
  • 1
    This is the way to get the functionality of the issues list, but still have the item-level permissions. If you don't need that functionality, then it doesn't matter what template you start from. – Erin L Aug 25 '16 at 13:47
  • 1
    A document library will never allow you to have item-level permissions. A list created from a Task list but containing Issue content type will let you have item-level permissions (without having to run any powershell). A list created from the Issue Tracking template will not allow item-level permissions. – Erin L Aug 25 '16 at 16:09
  • 1
    You could create a custom list template by following the steps I provided, then saving that list as a template. Then you'd only have to go through these steps once. – Erin L Aug 25 '16 at 16:14
  • 1
    @YogaPanda We're not talking about security/permissions settings. There's an option in lists to limit item permissions to only allow users to read and/or edit items they created. It's under List Settings >> Advanced Settings – Erin L Aug 29 '16 at 15:54
3

The Issue Tracking List is different from Custom List . Where its default WriteSecurity is 1 and can't be changed.

The main reason for that this list doesn't have an Item Permission Level in its Advanced settings List as Shown below.

enter image description here

Not Like The Custom List Item Level Permissions Settings.

enter image description here

[workaround]

  • Create A custom list.
  • go to advanced settings . > Allow content types.
  • go to add an existing content types Select > list group > Issues.
  • Set it as default.

enter image description here

  • now you can use issue content type with a custom list as Issue Tracking List With Item Permission Level.

enter image description here

Dear John I think you asked a similar question before at Modify the WriteSecurity property for an Issue Tracking List

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.