5

I have a SharePoint 2013 Web Application, where I have configured Anonymous Access. At the Site level, I have enabled Anonymous Access for Lists and Libraries. In one of the Libraries, I have broken the inheritance and Enabled Anonymous Access to View Items. The library has 3 files (2 DOCX and 1 XLSX). Even after doing all this, the library prompts for credentials when accessed. Also, I tried to give anonymous access to a single document and removed the anonymous access from the remaining 2 files. After doing this, when I tried to access the file which allows anonymous access, it still prompts for credentials. Not sure if I am missing something. Can anyone please help?

Note: Though I saw some posts with similar issues, none of them seem to have been answered. Hence I am creating a new post.

0

You must grant anonymous access at the Web Application level, in addition to anonymous access for the specific library/items.

https://social.msdn.microsoft.com/Forums/en-US/39217521-f037-4e87-9441-68be1178753a/how-to-grant-anonymous-access-on-sharepoint-document-librarylist-only-not-for-web-application?forum=sharepointdevelopment

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.