1

I have been tasked at work with making changes to an InfoPath form on a SharePoint site. The site is running SharePoint Services.

I managed to make the required changes of adding a couple basic text fields and making some changes to the wording. When I tried publishing is when things got weird.

I kept getting an upload size error when publishing so I manually uploaded the file to the Form Templates document library. When I tried opening the form it wouldn't open in the browser (as it had before). After some digging I found a solution that mentioned doing an Administrator-Approved Template.

I published it again as an Administrator-Approved Template and everything seemed to work fine; I was able to activate the template on the site collection and view the form in the browser.

When I try to fill out the form and submit it I get an error stating that it could not be submitted and an event log message was created.

Names removed due to sensitive information.

Source: InfoPath Form Services

EventID: 5567

Form submission failed. (User: DOMAIN\user.name, Form Name: Form Name, IP: , Request: https://domain/_layouts/FormServer.aspx?XsnLocation=https://domain/FormServerTemplates/Form Name.xsn&SaveLocation=https://Domain/Document Library&ClientInstalled=true&Source=https://domain/Document%2520Library/Forms/Document%2520Library%2520View.aspx&DefaultItemOpen=1, Form ID: urn:schemas-microsoft-com:office:infopath:Form-Name:-myXSD-2015-04-30T17-24-32, Type: DataAdapterException, Exception Message: The URI 'file:///\domain@SSL\DavWWWRoot\Document%20Library\' is invalid.)

  • I am interested in why you are getting upload size error. Maybe it is related. Can you find anything in SharePoint ULS log? – Mark L Aug 17 '16 at 1:32
  • re-create your data connections on form submit, and re-publish. Looks like they got corrupted. – billfredtom Aug 17 '16 at 5:48
  • I re-created the data connection and re-published the form (this time I eventually got it to go without the size error) and I'm still getting the same URI error on submission. – James Mazikowski Aug 17 '16 at 13:23
  • Well, it turns out I just added a new connection instead of recreating the corrupted one. Fixed that and now I'm back to the size error... "The file size exceeds the limit allowed and cannot be saved." Mark, I'm not really sure what I'm looking for in the logs. I can see the request coming in, but nothing that tells me what the problem is. – James Mazikowski Aug 17 '16 at 13:52
  • Were you publishing as a content type? And then switched to admin deployed? – hilary Aug 17 '16 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.