First of all, it doesn't have any to do with your code begin run in a web part (or any other specific position).
What really matters here is that you are creating a new instance of a
SPWeb object. Since these classes both implement the
IDisposable interface, and since you are creating the instances yourself (in contrast to getting them from another object, for example
SPContext.Current.Web to get the current web site) you are also responsible of handling the disposal of the instances you created.
As far as naming guidelines go, I don't think there is any SharePoint-specific guidance you should be aware off, so you probably should just stick to the generic naming guidelines provided by Microsoft, which means you should probably use camelCase for local variables names like these. As a side note, I would usually add the prefix "elevated" to the variable name if the instance was created in a
SPSecurity.RunWithElevatedPrivileges context, to remind me that any action I will perform on it will be performed under elevated privileges.