1

I have set up SSRS in integrated mode but am having trouble with getting it up and running.

When I try to run report builder model, report builder report or report data source in the report library I get a

The request failed with HTTP status 401: Unauthorized.

I then go to the report server and try to access a report in the web service URL and I get the following message

The report server cannot process the report or shared dataset. The shared data source 'DataSourceXML' for the report server or SharePoint site is not valid. Browse to the server or site and select a shared data source. (rsInvalidDataSourceReference)

any ideas? this is SharePoint 2010

0

You have 2 issues

Regarding The request failed with HTTP status 401: Unauthorized.

Reason :

The Reporting Services Web service is not configured to use Windows integrated authentication.

check the same issue at Reporting Services SharePoint Integration Troubleshooting

Regarding The report server cannot process the report or shared dataset

When reports and data sources are created in SSRS, they are assigned unique identifiers in the ReportServer database.

When reports are uploaded, they do not recognize an existing data source with the same name the report was built with.

So perform the following steps that should solve your issue:

  • Use IE, this will not work correctly in Chrome
  • Go to your report server
  • Click on the yellow arrow towards the right of your report name
  • Click on 'Manage'
  • Click on 'DataSources'
  • Provide the correct Credentials/data source settings are pointing to the right places.

Ref

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.