1

We have a client with a requirement for a search scope which will only return results of a specific CT - I figured I could do this with a new Result Source but the CT doesn't show in the Query Builder when selecting 'ContentType'

The CT is a site-scoped document set CT - I thought it may be because it's site scoped, not in the content type hub, so I created a new one in the CTB but found the same problem.

Any ideas?

0

What query are you using? I suspect that you are not using the correct query. I do this all the time and prefer the approach to using PATH. For example, ContentType=Contract will return all of the Contract content type documents.

  • Thanks for replying Matt - that's what I'm trying to do, using these values: Keyword filter = Only return items Property filter = ContentType Equals But the 'Vessel Information' CT doesn't show in the drop down when you click 'Show content types' Also when I add a CT that does exist it renders it as a hex value, not the text name - is that normal? In case it's relevant, the CT is part of the site, not the CT hub, and it's a path-based site. – Thomas Gass Aug 12 '16 at 8:43
  • Also I just tried creating the source at the site's search settings, not in CA (didn't realise you could do this) - the CT shows up fine. I guess if it is a site-scoped CT it'll only show for site-level sources... – Thomas Gass Aug 12 '16 at 8:54
  • I've found how to add the new RS to the drop down options, only question now is how do I configure the target URL for the drop down to use that result source? When I set it to the search center URL it just returns all results. – Thomas Gass Aug 12 '16 at 9:26
  • I am confused by your comments. Maybe you can clarify your question. What drop down are you referring to? Where in the UI are you attempting your changes? – Matthew McDermott Aug 12 '16 at 16:15
  • The drop down for the search box - I've got it sorted now, just need to work out with the client if they want it across all sites or on the specific one. Thanks for the help. :) – Thomas Gass Aug 15 '16 at 8:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.