The problem is that when trying to open a document to edit it, usually it prompts you with 'Read-only' or 'Edit'. I have rights to edit the document, but it the prompt does not show up. My colleagues do not have this problem. We have Office 2010 and Internet Explorer 10.

Kindly can you help me please?

Thanks

  • Any solution to this problem? – vikbehal Sep 11 '17 at 20:26

If the issue is related to specific people, you should make sure that office 2010 x86 has been installed on their machine , also Sharepoint designer will solve this issue.

Also you should make sure that Default open behavior for browser-enabled documents has been checked in library setting

Go to document library's Settings, > click Advanced Settings.> Find the option for "Default open behavior for browser-enabled documents", and select "Open in the client application".

Now, when a user clicks on the document name to open it, they will be able to see that they can edit it and select the "edit" option from the prompt (assuming you are using IE). Here is what that should look like:

enter image description here

Ref

  • The option for "Default open behavior for browser-enabled documents" is "Use the server default (Open in the client application)" . So it should open in the client application. – KMO Aug 10 '16 at 9:13

The read only or edit dialogue box shows up only if the document library has check in-out activated ( = turned on).

Other than that, you should get your IT personnel to perform a repair on Office.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.