0

Does anyone know how to map SharePoint 2013 on premis (using https, not http) as a network drive ?

  • process is same for http and https. Just make sure you site is in trusted list – Atish Dipongkor - MVP Aug 5 '16 at 6:40
  • @Atish I have completed the process for http - I could map as a network drive and open in explorer for http case in both SharePoint server machine and a remote machine. Also, I could also map SharePoint online instance to a network drive. But when i changed the bindings for SharePoint on-premis to only https. I cannot open in explorer anymore. Also network drive on my remote machine I mapped earlier is no longer available. – Puneet Aug 5 '16 at 6:45
  • Seems network issue. Try from another pc or domain pc – Atish Dipongkor - MVP Aug 5 '16 at 6:51
  • also check the issues from here nikpatel.net/2014/12/23/… – Atish Dipongkor - MVP Aug 5 '16 at 6:54
  • If you map a network drive using HTTP, then switch the site to HTTPS, your former network mapped drive will no longer function. It is like you want to access the site via the same HTTP-based URL as earlier. – pholpar Aug 5 '16 at 6:59
1

To map your HTTPS-based site to a network drive, yopu should use the format:

\\websitename\@ssl@port#\DavWWWRoot

like

\\www.yourwebsite.com\@ssl@443\DavWWWRoot

See the detailed description here and a few troubleshooting tips here.

  • I think I have created a self signed certificate which is a problem. I was able to open with Explorer before, when I was using HTTP. After that I created a self signed certificate which is not trusted by the browser and edited the bindings to use only https. Maybe this is the problem – Puneet Aug 5 '16 at 7:14
  • Of course you should have a certificate your operating system trusts. – pholpar Aug 5 '16 at 7:23
  • You also have to note that you do not enable "Server Name Indication" (SNI) in your IIS-Bindings. This will break WebDAV on older Windows-Clients (sharepoint.stackexchange.com/questions/94344/…). – MHeld Aug 5 '16 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.