I have a slight glitch in a webpart. On the webpart, after the page loads, the first time you click on a row, this error pops up. You can navigate to a different tab on the same page or click another row or use the select all checkbox and it will no longer do this. However, if you then refresh the page, it will do it again. I have seen a few others have this issue and they had to rebuild the whole page. The webpart works fine however, and you can do whatever you want, its just annoying so I want to get rid of it. Any thoughts??!

Update: 10/13 - It seems that in some cases, rebuilding the page exactly the same way corrects the issue. This is okay for smaller pages, but it is very tedious for larger more complex pages.

  • Using 'TabularView="FALSE"' in View definition solved this in my case. It's not really a good solution. Sep 7, 2011 at 13:42
  • Though this gets rid of the error, it does not allow me to do webpart connections on the rows. Pretty quirky problem. Sep 8, 2011 at 1:01

3 Answers 3


Might be a bug. Two posts that might help: http://chrissyblanco.blogspot.com/2007/12/bug-with-customaction-in-actions-menu.html and a solution here http://stephenkaye.blogspot.com/2008/02/bug-with-customactions.html

  • Appreciate the answer, but it does not seem to apply to my issue. I am using 2010 and an XsltListView. Sep 8, 2011 at 1:01

I too had this problem on an application page I deployed from visual studio to a publishing webs Pages catalog. When I declared the XsltListViewWebPart only in the aspx it almost worked but with mentioned error (expected hex 0x...) and my document tools in the ribbon could not be found.

I had to declare the parameters codebehind and it needs to be done before Page_Load() or OnLoad(). Not sure if OnInit() is right but it works for me :) Otherwise you get an error message saying that your view is invalid (don't know exact message since my error is in Swedish). The code I use is in a usercontrol:

    protected override void OnInit(EventArgs e)

        // This code must be run early or an error saying "Choosen view is invalid" will be displayed
        SPList list = SPContext.Current.Web.Lists.TryGetList("Documents");
        SPView view = list.DefaultView;
        mXsltListViewWebPart.Title = "Document library";
        mXsltListViewWebPart.ListId = list.ID;
        mXsltListViewWebPart.ViewGuid = view.ID.ToString("B");
        mXsltListViewWebPart.XmlDefinition = view.GetViewXml();
  • This is something to keep in mind, but I an not using code behind in this case. It is just an OOB webpart and is only declared on the .aspx page. Apr 27, 2012 at 11:26

I also think it is a bug....This seems to be the fix. Worked for me: http://developz.blogspot.com/2012/02/expected-hex-0x-in-0xdddddddd-etc.html

  • Welcome to SharePoint StackExchange. Although your answer may answer the question, links to blog posts often break, where as we won't be going anywhere for a long while. It's always a good idea to extract the useful parts for research if not all of it incase that happens (If it's not too long!) Please read the FAQ[1] for more information [1]:sharepoint.stackexchange.com/faq
    – Hugh Wood
    Dec 2, 2012 at 3:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.