0

I have a SharePoint 2013 site published in 2 address. In one I have a simple AAM and another I have the same more FBA (in a extended Web Application).

In the first, I no have any problems. In the second I have JavaScript errors and the Web Parts, lists and libraries are not loaded.

I have this errors in developer tools:

enter image description here

Someone can help me?

Edit

Function are getting error:

var _spRegionalSettings = {
    adjustHijriDays : 0,
    calendarType : 1,
    firstDayOfWeek : 0,
    firstWeekOfYear : 0,
    localeId : 1046,
    currentDateInLocalCalendar : new Date( 2016, 7, 12 ),
    showWeeks : 0,
    timeZone : '-03:00:00.0008461',
    timeZoneInHours : -3,
    workDayEnd : 1020,
    workDayStart : 480,
    workDays : '0111110',
    time24 : 1
};
Sys.CultureInfo.CurrentCulture = ( function( a ) {
    return new Sys.CultureInfo( a.name, a.numberFormat, a.dateTimeFormat );
} )( {
    "dateTimeFormat" : {
        "AMDesignator" : "",
        "AbbreviatedDayNames" : ["dom", "seg", "ter", "qua", "qui", "sex", "sáb"],
        "AbbreviatedLeapMonthNames" : null,
        "AbbreviatedMonthGenitiveNames" : [
            "jan", "fev", "mar", "abr", "mai", "jun", "jul", "ago", "set", "out", "nov", "dez", ""
        ],
        "AbbreviatedMonthNames" : [
            "jan", "fev", "mar", "abr", "mai", "jun", "jul", "ago", "set", "out", "nov", "dez", ""
        ],
        "Calendar" : {
            "AlgorithmType" : 1,
            "CalendarType" : 1,
            "Eras" : [1],
            "IsReadOnly" : false,
            "MaxSupportedDateTime" : "\/Date(253402300799999)\/",
            "MinSupportedDateTime" : "\/Date(-62135596800000)\/",
            "TwoDigitYearMax" : 2029
        },
        "CalendarWeekRule" : 0,
        "DateSeparator" : "\/",
        "DayNames" : [
            "domingo", "segunda-feira", "terça-feira", "quarta-feira", "quinta-feira", "sexta-feira", "sábado"
        ],
        "FirstDayOfWeek" : 0,
        "FullDateTimePattern" : "dddd, d' de 'MMMM' de 'yyyy HH:mm:ss",
        "IsReadOnly" : true,
        "LeapMonthNames" : null,
        "LongDatePattern" : "dddd, d' de 'MMMM' de 'yyyy",
        "LongTimePattern" : "HH:mm:ss",
        "MonthDayPattern" : "d' de 'MMMM",
        "MonthGenitiveNames" : [
            "janeiro", "fevereiro", "março", "abril", "maio", "junho", "julho", "agosto", "setembro", "outubro",
            "novembro", "dezembro", ""
        ],
        "MonthNames" : [
            "janeiro", "fevereiro", "março", "abril", "maio", "junho", "julho", "agosto", "setembro", "outubro",
            "novembro", "dezembro", ""
        ],
        "NativeCalendarName" : "Calendário gregoriano",
        "PMDesignator" : "",
        "RFC1123Pattern" : "ddd, dd MMM yyyy HH':'mm':'ss 'GMT'",
        "ShortDatePattern" : "dd\/MM\/yyyy",
        "ShortTimePattern" : "HH:mm",
        "ShortestDayNames" : ["D", "S", "T", "Q", "Q", "S", "S"],
        "SortableDateTimePattern" : "yyyy'-'MM'-'dd'T'HH':'mm':'ss",
        "TimeSeparator" : ":",
        "UniversalSortableDateTimePattern" : "yyyy'-'MM'-'dd HH':'mm':'ss'Z'",
        "YearMonthPattern" : "MMMM' de 'yyyy",
        "eras" : [1, "d.C.", "d.C.", 0]
    },
    "name" : "pt-BR",
    "numberFormat" : {
        "CurrencyDecimalDigits" : 2,
        "CurrencyDecimalSeparator" : ",",
        "CurrencyGroupSeparator" : ".",
        "CurrencyGroupSizes" : [3],
        "CurrencyNegativePattern" : 9,
        "CurrencyPositivePattern" : 2,
        "CurrencySymbol" : "R$",
        "DigitSubstitution" : 1,
        "IsReadOnly" : true,
        "NaNSymbol" : "NaN (Não é um número)",
        "NativeDigits" : ["0", "1", "2", "3", "4", "5", "6", "7", "8", "9"],
        "NegativeInfinitySymbol" : "-Infinito",
        "NegativeSign" : "-",
        "NumberDecimalDigits" : 2,
        "NumberDecimalSeparator" : ",",
        "NumberGroupSeparator" : ".",
        "NumberGroupSizes" : [3],
        "NumberNegativePattern" : 1,
        "PerMilleSymbol" : "‰",
        "PercentDecimalDigits" : 2,
        "PercentDecimalSeparator" : ",",
        "PercentGroupSeparator" : ".",
        "PercentGroupSizes" : [3],
        "PercentNegativePattern" : 1,
        "PercentPositivePattern" : 1,
        "PercentSymbol" : "%",
        "PositiveInfinitySymbol" : "+Infinito",
        "PositiveSign" : "+"
    }
} );
if ( typeof ( DeferWebFormInitCallback ) == 'function' ) DeferWebFormInitCallback();

function WebForm_OnSubmit() {
    _saveMarkedElems();
    UpdateFormDigest( '\u002fsites\u002fdist', 1440000 );
    var workspaceElem = GetCachedElement( "s4-workspace" );
    if ( workspaceElem != null ) {
        var scrollElem = GetCachedElement( "_maintainWorkspaceScrollPosition" );
        if ( scrollElem != null ) {
            scrollElem.value = workspaceElem.scrollTop;
        }
    };
    if ( typeof ( SP ) != 'undefined' &&
        SP.Ribbon &&
        SP.Ribbon.PageState &&
        SP.Ribbon.PageState.PageStateHandler &&
        SP.Ribbon.PageState.PageStateHandler
        .pageStateOnSubmit ) SP.Ribbon.PageState.PageStateHandler.pageStateOnSubmit();
    if ( typeof ( _spFormOnSubmitWrapper ) != 'undefined' ) {
        return _spFormOnSubmitWrapper();
    } else {
        return true;
    };
    return true;
}

Sys.WebForms.PageRequestManager._initialize( 'ctl00$ScriptManager',
    'aspnetForm',
    ['fctl00$WebPartAdderUpdatePanel', ''],
    [],
    ['ctl00$WebPartAdder', ''],
    90,
    'ctl00' );

WebForm_InitCallback();
  • Just the errors is not very useful. It would be more useful, if you also provide the information WHERE (in which files and on which position) these errors occur (just make a screenshot where the additional information for these error is "popped up". Could be a string that is closed too soon, some part which is expecting a exact URL (but in this case you have to make sure that everything is site-relative), ... – Leopold Lerch Aug 11 '16 at 6:28
  • You said "Web Parts, lists and libraries are not loaded" so it is not JS error but you have configuration problem in the FBA? – Mark L Aug 11 '16 at 7:00
  • Check the syntax which you have bind to the html. Also give those couple of lines so that one can check that issue!! – Ram Aug 11 '16 at 8:42
  • @mark the FBA configuration is correct. I have JS errors on browser, but the user can navigate and open links. – Diego Hillesheim Aug 12 '16 at 11:11
  • I have added the function are getting error. – Diego Hillesheim Aug 12 '16 at 12:38
-1

Make sure the scripts and webparts that you are using have sufficient user permissions. Also make sure that the scripts loaded are published and are shared with everyone in FBA.

  • Yes, the group everyone and everyone FBA users have read and edit permissions – Diego Hillesheim Aug 12 '16 at 11:11
  • Please check your master page, might be a possibility that some one must have put a script in master page and because of that error are being displayed in the browser – Muskan Aug 12 '16 at 11:15
  • I have checked, but aparently all is OK. I will check again, but I thinking is also in configuration of IIS. – Diego Hillesheim Aug 12 '16 at 12:32
  • I have added the function are getting error. – Diego Hillesheim Aug 12 '16 at 12:38
  • 1
    I down-voted 'cause this should've been a comment rather than an answer. – wjervis Aug 12 '16 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.