2

I am JR.System Admin in Sharepoint and I am trying to prevent anonymous users to access _layouts pages. I used this shell command with this instructions:

  • get-spfeature -site http:// maximum.dmzisbank

  • disable-spfeature viewformpageslockdown -url http:// maximum.dmzisbank

  • On Extend Site ( from page to the internet - _layouts/user.aspx ) disable anonymous accessing.

  • web application -> authentication providers -> from internet -> Enable Anonymous Authentication -> Uncheck

  • Execute Find-BrokenInheritance.ps1 -url http:// maximum.dmzisbank . (Remove the broken inheritances with this step)

  • enable-spfeature viewformpageslockdown -url http:// maximum.dmzisbank

  • web application -> authentication providers -> on internet -> Enable Anonymous Authentication -> check

  • from site of Extend ( from page to internet - _layouts/user.aspx ) enable anonymous accessing.

  • web application -> authentication providers -> on internet -> IIS Authentication Settings -> Integrated Windows authentication -> Uncheck

It does not work as I wanted and I have taken 401 Error​ after using this. So Does anybody know anything how can I solve this situation ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.