1

I am site collection administrator in SharePoint Online.

I enabled SharePoint Server Publishing Infrastructure in Site Collection Features. Now Views in my document library (/sites/sitename/Shared%20Documents) have a problem with Group by feature.

If only one column to group by is set under "First group by the column:", then the view shows items grouped as it should.

The problem starts when I set the secondary column to group by under "Then group by the column:". In this case, view shows items grouped by the second column and ignores the first one. Changing them around doesn't affect anything.

Also, this problem is present in only New experience. Views in Classic experience still work fine.

(Please do not suggest to just continue working with Classic rather than New, I really would like to fix it as it was before).

Disabling SharePoint Server Publishing Infrastructure did not revert this back.

  • you have possibly found a big bug – susan Aug 2 '16 at 11:24
  • I can only guess that if this thing is by design (despite being absurd) is because the new experience view has been created for mobiles and tablets and a double grouping does not look good on a small screen so they prevented it. – susan Aug 2 '16 at 11:45
  • If this could be of interest, I have just tested this on a non-publishing infrastructure site and you get the same problem. So I guess the fault here is not of the publishing infrastructure being turned on. – susan Aug 2 '16 at 12:02
  • @susan thank you for your input. The double grouping did work in New experience before enabling Publishing Infrastructure. When I was grouping a list view by two different columns, it showed all items grouped by the first column and then when I clicked on the group name, it was expanded (similar to like opening a folder) and grouping by 2nd column was shown. (hope that this makes sense). – Toms Lazdovskis Aug 2 '16 at 12:19
  • In my case out of 6 elements with different metadata, it does not matter what grouping I do (by metadata, by created by etc) it still shows the 6 elements one per line (so not grouped). This is both in publishing and non publishing sites collections. – susan Aug 2 '16 at 12:30
0

I am experiencing the same issue on a document library with the "New Experience" enabled, and SharePoint Server Publishing is NOT enabled either. First some background: I have two metadata columns: • Document Purpose, choice column, possible values: HR, IT, Training, Sales • Region, choice column, possible values: Northwest, Northeast, Southeast, Mid-Atlantic When I apply a view that groups by one column, it behaves as expected (although, I’m not sure about it now behaving like a folder when you click the column value instead of the carat, but that’s not the real issue here…). The real issue: when I apply a view that groups by two columns (in my case by Document Purpose, THEN Region), it only displays the values of the second group. So, when I apply the view, I only see the values of the second column. Something like this:

Northeast (2) Northwest (3) Southeast (6) Northeast (4) Northwest (1)

What it should (and does) show in classic SharePoint mode is this: Document Purpose: HR (5)) Region: Northeast (2) Region: Northwest (3) Document Purpose: IT (11) Region: Southeast (6) Region: Northeast (4) Region: Northwest (1)

I tried all of the typical fixes – clearing cache, switching to compatibility view, different browsers, rebooting, etc., and it still behaves the same. The only semi-workaround I have is to change the view to show the 1st column in my grouping (Document Purpose in my case) as column number 1 in the view, so you at least SEE its value when you expand the 2nd level grouping. My hope is that this is a bug (CSS or JavaScript issue?) that Microsoft will fix soon. If I had the time I would look for a CSS class I could show…. In the meantime, I’ll just use classic mode for libraries with 2 level groupings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.