0

I have a problem with a new RichHtmlField.

I Have a page layout with old RichHtmlField. the old one is working fine.

I created a new field. after I deploy the solution to my dev environment it works fine, but when I try to publish it to another server (with wsp file), the HTML field does not exist. I can see the div that wraps the RichHtmlField, but when I edit the page the item is not there.

can someone please help me with this problem?

Thank you!

  • Check if this RichHtmlField have a style that not located at the other server – Mohamed El-Qassas MVP Jul 31 '16 at 7:07
  • Hi,you mean css file? – Ben Jul 31 '16 at 7:13
  • the style of this field that is located in your CSS file, if not have style check the CSS linked to the site – Mohamed El-Qassas MVP Jul 31 '16 at 7:14
  • i didn't give the item any css style. just the div that wrap it. but when i check it on the other environment the div gets the style. – Ben Jul 31 '16 at 7:18
  • Ok try to match your destination with your source field also is the DIV have a style ? – Mohamed El-Qassas MVP Jul 31 '16 at 7:20
0

Update - The Problem was solved, after removing the field from the setting of the library. The problem occur because the filed name was not in English, so the field name in the url ("field=...") was in gibberish. after removing and reloading the column again, the problem solved.

Thank you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.