0

I've turned on 'Require content approval' option in Versioning settings for a document library.

I've set 'My submissions' view as default and deleted 'All Items' view, leaving only two views that were added for content approval, 'My submissions' and 'Approve/reject items'.

Everything was working great until I tested it logging in as a different user with Approve privilege.

It turned out that 'Approve/reject items' shows only items uploaded by the current user, just like 'My submissions' view.

I tried creating new views - they have the same issue. I tried turning 'Require content approval' off and back on, that didn't fix the issue.

Does anyone have a hint why it may be happening and how to fix it?

More details: I'm working on a subsite. I changed the default permissions of the site collection as well as on the subsite, they are not identical.

  • 1
    Do you by accident turned on item level permission? – Amal Hashim Jul 24 '16 at 3:10
  • What makes you think that? I did stop inheriting permissions on the library, so may be on to something, but I don't quite see the connection. – user2375527 Jul 24 '16 at 7:46
  • I am not talking about breaking permission. In list settings there is an option which says only display items created by user who uploaded the document. Just make sure it is not turned on. – Amal Hashim Jul 24 '16 at 10:53
  • Go to List Settings > Advanced Settings > Item Level Permissions. I guess you have set it to Read Items created by user. That's what Amal is talking about. – swdon Jul 24 '16 at 13:02
  • I'm working with a document library, not a list. There's no such option for document library. But it behaves exactly as if this option was turned on. It definitely has something to do with permissions. This is a subsite, and I've changed permissions a lot on collection and subsite levels. – user2375527 Jul 24 '16 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.