0

I am using SharePoint server 2010.

I have created a 'Project Tasks' page. I can see the Gnatt chart the default set of columns.

I would like to add a column where people can add notes or text related to that task. I added the 'Notes' column by doing the following -

List --> List Settings --> Columns --> Create Column.

I chose 'Multiple Lines of text' from column type.

I can now see the column in my Project Tasks page. But when i go to edit it, it is greyed out. Wont let me write any text to it.

Any idea why this is happening?

enter image description here

enter image description here

2

Multiple line of text field which has Rich Contents enabled is not editable in DataSheet View.

I think this is locked because the HTML content can mess up with DataSheet view.

Workaround is to convert the column into a Plain Text field.

Open List Settings -> Click on Notes Field -> UnCheck Enhanced rich text (Rich text with pictures, tables, and hyperlinks)

  • The column has been set to 'Plain Text'. I have attached a picture above to show all the settings for this column. – Quest Monger Jul 25 '16 at 2:03
2

This is because the multi-line text type is a rich text that is disabled by design

  • For SharePoint 2010 so you need to select a plain text as text type to can be able to edit columns in datasheet view .

  • For SharePoint 2013 you can select either a plain text or Enhanced rich text as text type to can be able to edit columns in edit view .

enter image description here

Hope it helps you

  • Column is set to Plain text. Please new screenshot attached above. – Quest Monger Jul 25 '16 at 2:04
  • Make sure that the site has added to compatibility view , local intranet sites in IE, – Mohamed El-Qassas MVP Jul 25 '16 at 7:49
0

This issue was caused by 'Inline Editing' being disabled by default. If I use the standard form to edit these rows, it works, and I am able to add text to these rows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.