0

I've been trying for days to get the SharePoint Powershell snap-in installed on my Win 7 machine, currently using Powershell 3.0 and SharePoint Online Management Shell. I've googled and googled and tried everything and it keeps failing. I've did the:

C:\Windows\Microsoft.NET\Framework64\v4.0.30319\InstallUtil /LogToConsole=true C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Microsoft.SharePoint.Power Shell\v4.0_15.0.0.0__71e9bce111e9429c\Microsoft.SharePoint.Powershell.dll

and that fails and rolls back each and everytime. It says its unable to get the installer types for the MS Powershell dll, yet the dll is there in hte directory its pointing to.

Even tried the Add-PSSnapin Microsoft.SharePoint.Powershell command, and keeps reminding me that i dont have the snap in installed

Any ideas on what I'm doing wrong here?

0

Try the below steps to configure it.

  1. Install Windows PowerShell 3.0 from Windows Management Framework 3.0.
  2. Install the SharePoint Online Management Shell from the Microsoft Download Center.
  3. Click Start>All Programs>SharePoint Online Management Shell.
  4. Run Connect-SPOService. For example, Connect-SPOService -Url https://contoso-admin.sharepoint.com -credential admin@contoso.com, where:
    • Url is the URL of the SharePoint Online Administration Center.
    • Credential is the user name to which you want to grant access to the SharePoint Online Administration Center site.

Read More Here: https://technet.microsoft.com/en-us/library/fp161372.aspx

1
  • if this is helpful and solve your issue then please mark it as answer with up vote – Waqas Sarwar MVP Jul 21 '16 at 22:12
0

That snap-in is for on-prem. You should be using the Client OM as mentioned here

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.