3

I can't create any folder through SharePoint interface(ribbon) in Document Libraries, and this happens only in document libraries and not lists across all of the Farm.
I have checked all things that came to my mind like:

  • My user is System Account and have full access.
  • My browser ran as administrator.
  • "Make "New Folder" command available" is YES.
  • "Allow management of content types" is YES.
  • Have no JavaScript error on the page.
  • Tried accessing through different client machines, but no chance.
  • In View settings "Show items inside folders" is selected.
  • Created new Folder content type from the main one and added to Library but no chance.
  • I'm able to create New Folder through Powershell, c# and Windows Explorer.
  • Client Integration is enabled for web application.
  • UAC is turned off, but still no luck. :(

I think this issue somehow related to the Farm and it's not a sitecollection problem or anything like that, because this problem is exist in all of my libraries in the farm.

This also happened one more time to me last year and i had to reinstall the SharePoint on another computer. I don't wanna do this again.

If happen to know any other way please tell me so i can test it.

Update
With @AmitKotha suggestions i noticed something else, when i added some new and existed content types to the "Documents" library, not only the New Folder button was disabled, the New Document button was also disabled.
In fact all of my ribbon button on Files tab was disabled except the Upload Document button.
enter image description here

I think it's ok that all of buttons is disabled since no item is selected but not the New Folder and New Document buttons.

  • this may sound stupid, but are you accessing the server remotely? try accessing through different client machines and check if the issue manifests itself everywhere – Tiago Duarte Jul 21 '16 at 8:46
  • @TiagoDuarte ,Thanks man for suggestion, i tested it but no chance. – Jalali Shakib Jul 21 '16 at 9:07
  • cant you test different sites, site collections and even web applications? in attempt to narrow down the issue – Tiago Duarte Jul 21 '16 at 15:53
  • @TiagoDuarte ,I checked some of my document libraries in all of the farm which some of them was in sitecollection and some was in subsites. And the problem was exist in all of them. – Jalali Shakib Jul 23 '16 at 4:50
1

In view settings, If the option to show items without folders is selected, then the "New Folder" button will be disabled in SharePoint

enter image description here

  • 2
    it doesn't really disable folder creation at the library level. it "prevents" the creation of folders in the specific view where the setting was applied to. – Tiago Duarte Jul 21 '16 at 9:57
  • @AmitKotha ,Thanks for this. I already tested it but forgot to mention it in my question. This also not solved my problem. – Jalali Shakib Jul 21 '16 at 10:02
0

I had similar issue in the past (but with Sharepoint on premise). The library that had greyed out folder option had actually not 'Folder' content type (it was removed using PowerShell). Folder content type is hidden so you don't see it via UI. Easiest way to test if that is the case is to create custom folder content type (with Folder as parent) and add it to the library to see will that enable (or use Sharepoint Manager to check all content types). On another project I have found there was custom javascript that was disabling some functions in Ribbon (not the folder in that case but same principle may be applied in your case)

  • Some good points you mentioned here. I created a new folder content type inherited the main one, but not a chance. I also had some JavaScript links which was added to site collection through CustomAction but since this problem was existed on some other site collections which this JavaScripts wasn't existed, i can assume this should not be it. – Jalali Shakib Jul 23 '16 at 5:16
  • Have you tried to create the folder using PowerShell? If it fails the ULS log may give you some clue to why this is happening. – Marek Sarad Jul 26 '16 at 9:28
  • I tested it, and i was able to create new folder by powershell and c#. – Jalali Shakib Aug 9 '16 at 9:21
0

Try these 2 things. Ensure you are using the 32 bit version of IE. Navigate to the Program Files (x86) directory to find iexplore.exe. Second, ensure that compatibility view settings includes the domain "example.com" of your site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.