2

I am getting following error while trying to deploy solution from SharePoint Central Administration:

The requested operation could not be completed due to a file system limitation

It happened all of a sudden as it was working fine before.

Also, after this error, I tried to build some solutions, and got the same error there also with failed build operation:

Error 1 Cryptographic failure while signing assembly '<>' -- 'Error signing assembly -- The requested operation could not be completed due to a file system limitation '

Appreciate your help on this.

  • is it possible you are hitting an actual "system limitation", e.g. 260 characters in the path or some other NTFS/Windows file system limitation? – Tiago Duarte Jul 19 '16 at 18:01
  • @TiagoDuarte Don't think so. As of now I could understand that it can be because of the heavy disk fragmentation on server. – Vishal S Jul 20 '16 at 5:42
0
  • Hi Qassas, No restore has been made and no untrusted DLL is there in my solution. As I mentioned in the question, it happened all of a sudden. No specific changes has been made. Just one normal functionality code has been checked in before this error occurred while deployment. Also, getting the same error while running the strong key command, as mentioned in link provided by you. Thanks. – Vishal S Jul 19 '16 at 11:14
  • Are you can rollback code check-in and try to check if the issue still exists – Mohamed El-Qassas MVP Jul 19 '16 at 12:00
  • Checked with check-in rollback, but issue still exists. Now facing issues with other solutions as well. – Vishal S Jul 20 '16 at 5:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.