2

My problem is very strange.

In a SharePoint server 2013 site collection with user experience 2010. The choice field is set to "allow fill-in choices".

The problem is that we can't "specify your own value". the field is grey like disable.

I can't know where this problem comes from. Has somebody an idea? thanks

  • Have you tried in different browser and from different machines? – Amal Hashim Jul 18 '16 at 19:56
  • Yes. the problem is the same .. – Miguelafz Jul 20 '16 at 8:22
  • We are experiencing this same issue in our 2013 Farm with 2010 compatibility mode. This happened when we upgraded to SharePoint 2013 June 2016 CU. Before that we were at February or April 2016. Testing with the 15 Hive form.js file fixed it, but then broke attaching files to list items. Working with MS on this now. – DLDorn Aug 4 '16 at 19:46
1

Viewing with console development browser, I find the source problem :

 SetDisabledOnControl function is unknown.

This post indicates the source problem is an UC update. But I can't test the proposition on this post to validate it.

I think it's dangerous to edit a forms.js file on a PROD server.

The solution is to upgrade this site collection to user experience 2013.

Thanks for the help

0

You need to check if the user with whom you try to add value to choice field is having "Contribute" access on the list/library in which this field has been added.

  • I tried with full-control permissions without success – Miguelafz Jul 20 '16 at 8:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.