I'm trying to open some SharePoint files with the full office apps, but the applications always crash the instant after opening the files.

This doesn't happen with files created using the sharepoint web interface and then opened with the client and some random files we have uploaded.

Any idea what is going on?

EDIT: I tried to use this question to fix the problem, but to no avail Unable to open office files in Office client

EDIT 2: The files do open correctly using Office Web Apps

EDIT 3: Interesting discovery. The crashes occur whenever any of the client apps, try to access the SP server. For example, I opened a Word instance and tried to save the default file (the empty document you begin with) to the SP server using the 'Save & Send -> Save to SharePoint option' and after choosing the place I wanted to save in the SP hierarchy and clicking 'Save' Word crashed. Same thing happened with both PowerPoint and Excel.

EDIT 4: Trying to track down the problem, I used fiddler to see the network operations that are going on and I word receiving a bunch of 401 responses when trying to open the files. Not all responses are 401 though, some are successes. I therefore tried to enable anonymous access for the Site Collection, but still no solution.

  • 2
    What version of Office is crashing and is it any specific application, i.e. excel always crashes but word doesn't? Are the documents that cause the crash the newer format (.docx, .xlsx) or old format (.doc, .xls)
    – Dave Wise
    Sep 1, 2011 at 14:23
  • Can you provide more details on exactly the error(s) you're seeing? Do you see an error message?
    – Rob D'Oria
    Sep 2, 2011 at 0:32
  • @Dave - Office 2010 (both Standard and Professional Plus). It happens with both files formats.
    – Carlos G.
    Sep 2, 2011 at 18:18
  • @Rob - No errors, just a straight application crash. The only thing I just realized is that it happens when I try to edit the document. So if the copy of office is configured to show in protected view first, it will open the file and when I click 'Enable Editing' crash. If it is configured to open the file directly, it will crash as soon as it is opened with a non-specific error
    – Carlos G.
    Sep 2, 2011 at 18:22
  • @Rob - Checking on the window logs i found this: Problem Event Name: APPCRASH Application Name: WINWORD.EXE Application Version: 14.0.4734.1000 Application Timestamp: 4b58fb0e Fault Module Name: wwlib.dll Fault Module Version: 14.0.4734.1000 Fault Module Timestamp: 4b58fba1 Exception Code: c0000005 Exception Offset: 00612404 OS Version: 6.1.7601. Locale ID: 1033
    – Carlos G.
    Sep 2, 2011 at 18:26

3 Answers 3


Try adding the URL of your SharePoint site to the list of "Trusted sites" in IE. This could definitely be the problem if you are using a hosted SharePoint site because the crashing would be caused by an authentication issue when SharePoint is trying to check if the user has permission to edit the document, hence the 401 error.

Anonymous users cannot edit documents, which is why that work around did not work.

If you aren't using IE, then what browser are you using? Does it work if you do use IE?


Have you ruled out if it is just your office instance (i.e. does the same thing happen on other systems)?

If you download them first locally, than open them does the same thing happen? Assuming it does..

If it is just you, you can try and do an office repair, and possibly uninstall / re-install SharePoint add-on.

If it is everyone, then the files may have become corrupt in some manner. MS office clients can attempt to repair damaged files. Download the files locally, open the appropriate office client directly (not via your downloaded documented), from inside the client select Open, and click the small arrow next to the open button and select "open and repair", browse to your file and attempt to open.

  • It happens on every computer I have tried. Some are running office 2010 Standard, others PRofessional Plus. - If I open the files locally, they open perfectly. How can I re-install the sharepoint add-on?
    – Carlos G.
    Sep 2, 2011 at 18:16
  • When you do an install or change you will find it under the Office Tools Node --> Windows SharePoint Services Support. However, unless you deployed your machines from a common image, I doubt that would be it, but certainly wont hurt to try. Sep 2, 2011 at 20:34
  • I tried to reinstall the SharePoint Services Support, but it didn't help
    – Carlos G.
    Sep 7, 2011 at 15:04
  • I would take a look at running a Fiddler/Wireshark and inspecting the traffic. If there are no connection issues you could then move on to running Process Explorer on both the Client and the Server and watch what is happening when you perform the action. Sep 14, 2011 at 20:09
  • My 4th edit has the results from the Fiddler run
    – Carlos G.
    Sep 16, 2011 at 5:44

Have you tried any of the fixes in the following KB Article:


Pay particular attention to the ones related to the registry, especially if these workstations were upgraded from a previous version of Office to 2010.

  • The workstations were not upgraded, are have a clean install of office 2010 with no custom add-ins (not even Adobe PDF)
    – Carlos G.
    Sep 7, 2011 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.