2

First off, I've been scouring the posts here and elsewhere looking for a solution to this issue, and I appreciate any help. The closest I have found is here, but the answer was not followed-through. My apologies if this is a "obvious" question as I'm new to SP development and have recently inherited this farm from the previous admin. I am trying to add a new application server to the farm to facilitate search indexing as it has become too much to handle for the single server that currently comprises the farm.

The error message I am getting when adding the server (either through the wizard or powershell) is:

Connect-SPConfigurationDatabase : Failed to apply web.config modifications to file
'E:\Inetpub\SharePoint\VirtualDirectories\80\web.config'. Failed to apply a web.config
modification to file 'E:\Inetpub\SharePoint\VirtualDirectories\80\web.config'. The
specified node "configuration/system.webServer/staticContent" was not found in the
web.config file.

I have checked the file, and this node is present and populated. Also, I have verified permissions for this account on the SQL server in case that matters. Both servers are on the June 2016 CU, and I have also made sure the passphrase is correct by changing it a few times. This caused a need to rebuild the cache so that has been completed, also. I'm not sure where to go from here.

  • which web.config is giving error? central admin or web application or? – Waqas Sarwar MVP Jul 14 '16 at 15:37
  • This web.config is for the main web application. – Jeremy Neisess Jul 15 '16 at 16:47
  • How any servers in the farm – Waqas Sarwar MVP Jul 15 '16 at 16:49
  • The Web Config is case sensitive. Make sure you check the case of the nodes. – James Grizzle Jul 15 '16 at 18:01
  • One WFE application server in the farm and one SQL server. Trying to add a second application server. – Jeremy Neisess Jul 16 '16 at 17:28
1

try this one

  • go to the IIS Manager, Click on the Server and in the feautre pane select the configuration Editor
  • On this page from drop down Exapand System.WebServer and Click on the StaticContent
  • Now on in Action Tab(right hand side) Make Sure it say Lock Section if not then unlock it.
  • Do this on all Servers and reset IIS.

This link is basically go through the above steps

http://social.technet.microsoft.com/wiki/contents/articles/33768.sharepoint-2016-central-admin-error-http-500-the-website-cannot-display-the-page.aspx

  • The section shows as unlocked with the "Lock Section" option available. – Jeremy Neisess Jul 16 '16 at 17:29
  • Ok then click on unlock, it should say locked and re ran the config wizard? Make sure it shows lock on all server especially on the new server – Waqas Sarwar MVP Jul 16 '16 at 17:32
  • To clarify, under Actions > Section it should say "Lock Section" or "Unlock Section"? It currently shows "Lock Section" – Jeremy Neisess Jul 16 '16 at 17:51
  • It should say lock section – Waqas Sarwar MVP Jul 16 '16 at 18:40
  • Yes, that is what is currently showing. Could this message also appear if there's an issue connecting to the configuration database? – Jeremy Neisess Jul 16 '16 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.