0

I am creating web application on port 80 with host header beta.xxx.com with DOMAIN\spadmin account with Allow Anonymous access. Then I create site collection. Everything goes correct.

Now when I try to access the website outside server on internet beta.xxx.com then it will ask for user password which I provide and website opens but when I try to access Site Settings it always ask for username and password never stops.

What can be the reason for it. !!!

  • did you try to add site into the trsuted site zone of browser? – Waqas Sarwar MVP Jul 14 '16 at 14:45
  • Well I just found out that it is sign in from IE but not from chrome & FireFox and Yes it is added to trusted zone – Milind Jul 14 '16 at 14:48
  • what version of IE? have you tried with Compatibility mode enabled? – Waqas Sarwar MVP Jul 14 '16 at 14:49
  • As I told you it working from IE and not working from chrome & Fire Fox – Milind Jul 14 '16 at 14:55
  • My bad i read it is not working in IE but chrome and firefox...check this one sharepoint.stackexchange.com/questions/53020/… – Waqas Sarwar MVP Jul 14 '16 at 14:59
1

You can try disabling loopback check as explained in the KB - https://support.microsoft.com/en-us/kb/896861

Method 1: Specify host names (Preferred method if NTLM authentication is desired)

To specify the host names that are mapped to the loopback address and can connect to Web sites on your computer, follow these steps:

  1. Set the DisableStrictNameChecking registry entry to 1. For more information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base: https://support.microsoft.com/en-us/kb/281308
  2. Click Start, click Run, type regedit, and then click OK.
  3. In Registry Editor, locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
  4. Right-click MSV1_0, point to New, and then click Multi-String Value.
  5. Type BackConnectionHostNames, and then press ENTER.
  6. Right-click BackConnectionHostNames, and then click Modify.
  7. In the Value data box, type the host name or the host names for the sites that are on the local computer, and then click OK.
  8. Quit Registry Editor, and then restart the IISAdmin service.

Method 2: Disable the loopback check (less-recommended method)

The second method is to disable the loopback check by setting the DisableLoopbackCheck registry key.

  1. To set the DisableLoopbackCheck registry key, follow these steps: Set the DisableStrictNameChecking registry entry to 1. For more information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base: https://support.microsoft.com/en-us/kb/281308
  2. Click Start, click Run, type regedit, and then click OK.
  3. In Registry Editor, locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  4. Right-click Lsa, point to New, and then click DWORD Value.
  5. Type DisableLoopbackCheck, and then press ENTER.
  6. Right-click DisableLoopbackCheck, and then click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. Quit Registry Editor, and then restart your computer.
  • I did both the option but still same it did not works – Milind Jul 14 '16 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.