0

I'm using Sharepoint Online to try to fit the following workflow use case:

User with very limited permissions submits a form to create a new list item. This kicks off an approval workflow and sends the approval to a group based on a combo box selection in item form.

What is happening is the group is never expanded and the task processes are not assigned to individual members, even though that workflow action is set that way. I even tried putting it in an app step and that seems to make zero difference.

If I, an admin, start the workflow, it works fine and expands the group and assigns tasks properly.

Here are the permissions the intended submitting user has:

Add Items, Edit Items, View Items, Open Items, View Versions, View Application Pages, View Pages, Browse User Info, User Remote Interfaces, Use Client Integration, Open, Edit Personal User Info.

Does anyone know what is going on? I saw that there seems to be a known issue with SP 2013 and the expand groups function, but it was unclear whether it was fixed in SP Online.

Thanks

0

Turns out that the groups that were setup to be selected via the combo box were not set to be visible to Everyone. Once I did that the group expansion function worked properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.