0

From the Central Administration in Sharepoint 2013, we have a stange error when we do this :

  1. Click on Manage Service Application
  2. Click on Secure Store Service Application
  3. Click on New option in the Ribbon. Same if we try to modify an existing one.

The error that appear on screen is :

Session state can only be used when enableSessionState is set to true, either in a configuration file or in the Page directive. Please also make sure that System.Web.SessionStateModule or a custom session state module is included in the \ section in the application configuration.

We try to restart the Secure Store Service.

We also try this command in powershell : Enable-SPSessionStateService -DefaultProvision

Any idea ?

2

The first is to ensure that enableSessionState is set to TRUE.

<pages enableSessionState="true" enableViewState="true" enableViewStateMac="true" validateRequest="false" pageParserFilterType="Microsoft.SharePoint.ApplicationRuntime.SPPageParserFilter, Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" asyncTimeout="7"> 

The second is to ensure that the remove and add lines exist in the modules section for Session.

<modules runAllManagedModulesForAllRequests="true">
…
<remove name="Session" />
<add name="Session" type="System.Web.SessionState.SessionStateModule" preCondition="" />
…
modules>

Read more here: http://www.kajanmoorthy.com/2010/05/enable-session-state-in-sharepoint-2010.html

Also have a look on this one http://fangdahai.blogspot.com/2013/03/sharepoint-2013-session-state-can-only.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.