0

Iam seting up my development enviroment on Hyper-V virtual machine, and every thing works fine on SQL server. I can ping sql sever by ip and servername. But when i run AutoSPInstaller i get an error:

WARNING: Connection Error. Check server name, port, firewall. - This may be expected if e.g. SQL server isn't installed yet, and you are just installing SharePoint binaries for now.

I have checked that sp_admin have correct dbcreator, securityadmin rights on SQL server instance. And named pipes and tcp/IP is enabled. I have also checked access to SQL server by telnet port, and it connects to the server . And FireWall is turned Off on all of my Hyper-V servers

What are i missing here, or how can i fix this issue?

  • check if you are putting correct SQL server name( no typo) and no instance mismatch. This is what i am thinking – Waqas Sarwar MVP Jul 10 '16 at 14:26
  • sql server name is correct, i can ping sql server by its name and ip. i can even telnet servername and portnumber....still cant figure out why iam still getting this error, i just tried to run SharePoint Configuration wizard, and i got samme error... – user3629354 Jul 10 '16 at 15:23
  • are you login with the account who has permission on SQL server? – Waqas Sarwar MVP Jul 10 '16 at 15:27
  • have you created the alias to the SQL server? if yes via script or manually? – Waqas Sarwar MVP Jul 10 '16 at 15:29
  • iam just usin the script, not done anything manually. i can se that by cliconfg on SharePoint server connection parameters and server alias are correct.... – user3629354 Jul 10 '16 at 15:52
1

The issue was when we let the scrip create the DB alias, our environment didn't like it. We created the alias manually first using SQL Server Configuration Manager.

Under SQL Native Client 11.0 (32bit) --> Alias and SQL Native Client 11.0 Con --> Alias (you need to do both sections), right click, new alias type your alias name "SharePointDB" and fill out the parameters.

For us the server was the server we were on since it's a dev box right now but you would put your SQL server in there. We also had to use named pipes since TCP/IP also through this error. We plan to look into this before prod.

Once you have manually created the alias, uncheck or remove the "create alias option" and simply reference your new alias name.

Quote from here: https://disqus.com/home/discussion/autospinstalleronline/autospinstaller_online_home/

| improve this answer | |
  • i just managed to run SharePoint configuration Wizard by deleting alias from cliconfg, and as you described i putt Alias in: SQL Native Client 11.0 (32bit) --> Alias and SQL Native Client 11.0 Con --> Alias. But i still can not run sharepoint installation by AutoSPInstaller, i removed creating of Alias in the script xml file, but then i got other errors comlaining about dbserver is not specified....! Seems like its some kind of bug on creating Alias by scripts dosent work.....?! – user3629354 Jul 10 '16 at 16:28
  • Yes it is bug in auto installer...try to create manually and put that reference it as mentioned – Waqas Sarwar MVP Jul 10 '16 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.