0

I have got a farm where the User profiles are synced through AD Import. I changed the settings to use Sharepoint User Profile synchronization to run a full crawl on the farm. When I tried to start the synchronization service on the server where it runs the UPA, it asked for credentials to start the service.

The UPA pool account is a different one from farm account.By mistake I have keyed-in the farm account and I am unable to start the User profile Synchronization service. I tried to change the account through UI but it is greyed out.Is there any way to change the account and try starting the synchronization service?

  • u trying to start the service from Service console or from SharePoint. You cant the change of the Sync Service as it runs under the farm account but you can change the UPA pool account – Waqas Sarwar MVP Jul 9 '16 at 16:24
  • The app pool account with which it is configured currently has the rights to connect to AD directory to import the data. I tried to start the service on the server by going to CA->SystemSettings->Manage Services on the server. For the first time before starting the User Profile sync Service it asked for Creds.The next time by default it took the previous keyed-in value. – Vishal Jul 9 '16 at 18:14
1

In your case you don't need to change the UPS account , and to start the UPS service you should use the farm account meanwhile the farm account should be added to local administrator group during starting and provisioning UPS service.

Keep in mind, adding the farm account to local Administrator group is required only to start the User Profile Synchronization service.

After the User Profile Synchronization service has been started, you should remove the farm account from the Administrators group to avoid raising security warning in Health Analyzer.

For more details you could also check this link

  • Thanks for the suggestion. I found that the UPA service was not configured properly and the service was not starting in the intended servers. I have created a new User Service application & the AD import is working fine. – Vishal Jul 13 '16 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.