0

I am successfully able to configure SSL and redirecting users from HTTP to HTTPS using AAM.

Here are the settings I've used in AAM-

Public URLs

    URL                               Zone
    http://sharepoint                 Default
    https://subsite.site.com          Internet

Internal URLs

    URL                               Zone
    http://subsite.site.com          Internet

I want to achieve this only with Central Administrator. I don't want to edit my web.config file or edit URL Rewrite in IIS.

Please suggest me on how can I resolve this?

1

if you configure the SSL certs at IIS, then i think following the AAM settings will fix the issue. You need to add internal urls

  Internal URL              Zone           Public URL for Zone 
 http://subsite.site.com        Default     https://subsite.site.com    
 https://subsite.site.com   Default     https://subsite.site.com  
  • If I put https://subsite.site.com as default public URL then I think it would not load the site at all..because in IIS site is at sharepoint – Kamalpreet Jul 9 '16 at 16:05
  • why you think this? what are your IIS settings? if you want redirect http to https from sharepoint to subsite.site.com – Waqas Sarwar MVP Jul 9 '16 at 16:07
  • According to these settings, if user tries to open http://subsite.site.com then it won't load at all, right? – Kamalpreet Jul 9 '16 at 16:14
  • no, from this settings if you try to open sharepoint then it will redirect to subsite.site.com – Waqas Sarwar MVP Jul 9 '16 at 16:15
  • Ok, I think you misunderstood this. http://sharepoint is url which can only be accessed from the server. It's like localhost:12345. – Kamalpreet Jul 9 '16 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.