1

Using cross-site publishing with managed navigation and friendly urls. I had a term with a space in it, Dark tan, which SP automatically changed to a url location of dark-tan.

For the category pages located at //colors/dark-tan, the CSWP worked just fine and retrieved all items with that tag. But when I clicked one of those items to go to the item details page //colors/dark-tan/378 nothing was displayed.

If I changed the friendly url to something like //colors/darktan/378, then it worked as expected.

I found I could use space character (got changed to %20 in the browser) and other characters like +. Any idea why an item page can't accept a dash in the url?

  • Also breaks with underscore! Crazy. – Rothrock Jul 8 '16 at 17:51
  • Just ran into this again. One site they work another site they don't. Anybody? – Rothrock Jul 11 '17 at 21:00
  • I'm having the same issue. Please let me know whether anyone knows how to fix – Siva Prasath Oct 23 '19 at 19:17
  • Finally fixed it. On Search schema we have to ensure On FriendlyURL, "Complete Matching" is enabled – Siva Prasath Oct 23 '19 at 20:07
  • Can you explain this a bit more? Did you do this at the site collection or site level? And if it is on you get hyphen and not checked you get %20? Or the other way around? Did you have to re-index or anything else? – Rothrock Oct 23 '19 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.