1

Hello SharePoint folks,

The problem shared below is occurring only on the Production Environment and we are unable to simulate this in any other environment.

Environment: SharePoint 2010 Server (Farm Solution)

Problem: At random times (once/twice a week), the users don't see any data on our SharePoint site. Data refers to the list items that we show on the Visual WebParts, which is retrieved via code. We are using LINQ.

Observation: When this problem happens, we see the below error in the SharePoint ULS.

GetPendingClearancesClearancesDAC Value does not fall within the expected range.    at Microsoft.SharePoint.SPFieldMap.GetColumnNumber(String strFieldName, Boolean bThrow)     at Microsoft.SharePoint.SPListItemCollection.GetColumnNumber(String groupName, Boolean bThrowException)     at Microsoft.SharePoint.SPListItemCollection.GetRawValue(String fieldname, Int32 iIndex, Boolean bThrow)     at Microsoft.SharePoint.SPListItem.GetValue(SPField fld, Int32 columnNumber, Boolean bRaw, Boolean bThrowException)     at Microsoft.SharePoint.SPListItem.GetValue(String strName, Boolean bThrowException)     at Microsoft.SharePoint.SPListItem.get_Item(String fieldName)     at Microsoft.SharePoint.Linq.PropertyMap.GetSPFieldValue(PropertyMap pm, SPListItem item, JoinPath joinPath)     at Microsoft.SharePoint.Linq.PropertyMap.GetFromListItem(DataContext dc, SPListItem item, Object entity, JoinPath joinPath)     at Microsoft.SharePoint.Linq.SPItemMappingInfo.MaterializeEntity[TEntity](DataContext dc, SPDataList list, SPListItem item, SPItemMappingInfo itemMappingInfo, JoinPath joinPath)     at lambda_method(ExecutionScope , SPListItem )     at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext()     at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)     at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)     at XXX.ABCPortal.DAL.ClearancesDAC.<>c__DisplayClass166.<GetPendingClearances>b__131()     at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass4.<RunWithElevatedPrivileges>b__2()     at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)     at XXX.ABCPortal.DAL.ClearancesDAC.GetPendingClearances(String requestURL, String clearanceDepartment, Double departmentApproverSPN)

Workaround: Restart IIS and things become normal. Until we reset IIS, our SharePoint Solution does not show any data in the Visual WebParts.

Additional Info: We have two lists which have item count of 7000 and 6000 items. From the google search we found that the Error Message that we get is due to Throttling issue. We even pumped up the Throttling setting in Central Admin, but it was of no help. There is hardly any Lookup columns used. If throttling is the issue, then why does the application works well after IIS restart?

Can anyone please share some thoughts to troubleshoot this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.