0

I am the Site Admin on a company based SharePoint 2010 site. I created a workflow on a SharePoint list about 3 weeks ago. The workflow was designed to

  1. Copy a list item to a archive list if the item was status "Complete"
  2. Delete the item from the Primary list.

Everything worked great when I was trigger 2-4 items, then I went into datasheet view and tried to fire the workflow off by stating about 50 items at the same time. Something locked up. Since then I cannot delete any list item in this list.

I get the error message "The server has uncounted the following error(s) Cannot complete this action. Please try again". Or, I will get a "Correlation ID" error code.

I have stopped and deleted the workflow. Still cannot delete any item in that particular list. (No problem deleting items in other list). I do not have access to the SharePoint server farm. I have submitted a trouble ticket but their response is the issue is not server based, it has something to do with my list.

Need help, is their something I can try on my list or is their something I can advise the company SharePoint Admin to look at?

  • looks like the workflow is not able to handle large requests and thus get stuck,is that designer workflow?have you double checked the wf logic?also try to restart timer job service once and see. – user13408 Jul 3 '16 at 3:48
  • Do you have a correlation id. If yes, can you get the log message? – Juan Pablo Pussacq Laborde Jul 4 '16 at 12:36
  • I have completed deleted the workflow and all running instances. I am not sure what you mean by "restart timer job service". I have never done that. Can you be a bit more specific on how to do this? I do get a Correlation ID but that is just a time stamp for when the issue occurred. There is no information there that informs what may be causing the error. I do not have access to the Correlation Logs on the server. – J.Mac Jul 5 '16 at 2:25
0

Can you check list and item level permissions and see if you have full control permission to delete an item.

  • Yes I have full control. I am the Site Admin. I can do everything except delete a list item. Issue just started after workflow issue – J.Mac Jul 2 '16 at 3:13
0

As site collection administrator, is your account a system account? You can check simply, if you have sys account, your name/id is replaced by word 'system'. Thing is system accounts treat several things differently, e.g. they can edit list items without changing modify date. If your WF was running under such account it may have caused some trouble in content DB.

Other option: check WFs running on list (or WF history). Even if you deleted your workflow there still might be an instance in faulted/unfinished state. You have to terminate it there.

I also advise to check your WF logic. It's not healty to process items in parallel. It can take time until item is properly handled by DB, so you need to avoid e.g. repeating check for item in 'complete' status because you can get item you already tried to delete again, meaning it didn't have enough time to be deleted in DB. (personal experience)

0

It's only hypothesi :

  • your list is from a custom list template ? (if yes, your custom list template may have been deleted).
  • May be there is Lock on all your items. you start workflows on your items, The Workflow Manager Lock you item, do the stuff and release the lock. You have started 50 workflow in the same time, may be the workflow manager crach and do not release the Lock on items

If you can have the ULS log when you try to delete an item it will be nice.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.