2

I have a Share Point list in SP2013 which has more than 5000 items. I need to display all Items(More than threshold)in view without applying filters. Its not working for few lists.I tried creating new view, still its giving threshold error.

There is another list which is also having more than 5000 items but still it works.

4

Threshold is not a boundary or a limit, instead it's a restrictiona in which the default value can't be exceeded unless that value is explicitly modified.

You can not set List View threshold for a single list. This can only be done on Web Application level. Follow these steps:

  1. Login to Central Admin
  2. Go to Application Management -> Manage Web Applications
  3. Pick the Web application for which you want to change the LVT (If you only have 1 web app plus the central admin one, the one you want to pick is the 1 web app; changing this for the central admin does you no good)
  4. In the ribbon above, click General Settings. That will bring down a menu, from which you should pick Resource Throttling
  5. Change the LVT (first item in this list) to another value and press OK, but please try to keep it to a reasonable number!

Full article here

On the other hand, you can disable throttling for a single list using SharePoint Manager or the following PowerShell commands:

$web = Get-SPWeb http://myserver
$list = $web.Lists["MyCustomList"]
$list.EnableThrottling = $false
$list.Update()

Consider using folders in the future. As keeping all the eggs in one basket is a bad habit :)

0

Prashant,

Can you confirm the list that shows all list items is from same web application. If its different application then there is setting that can be done on web application that change list view threshold although it is not recommended by Microsoft.

The setting for the list throttle

Open the SharePoint Central Administration, go to Application Management --> Manage Web Applications Click to select the web application that hosts your list (eg. SharePoint - 80) At the Ribbon, select the General Settings and select Resource Throttling Then, you can see the 5000 List View Threshold limit and you can edit the value you want. Click OK to save it.

  • Hi Pradeep, Both lists are on same site collection, at same level. I dont understand how behavior is different for lists are same site collection. – Prashant Nagouda Jul 1 '16 at 17:35
0

If no filtering then possible solutions are

  • Increase the List View Threshold, if your hardware is enough you can increase it without fear.
  • or Set up the daily time window for the large query. In this case you will access the list during that time frame without any issue.

Read more here: http://www.abelsolutions.com/2013-blog/working-with-list-view-thresholds-in-sharepoint/

  • Hi Waqas, We don't have access to Central admin. Also we dont want to change LVT from CA. – Prashant Nagouda Jul 1 '16 at 17:38
  • then you have to find out the timings when the large query window is or login as the Site collection admin...as by default Site collection admin LVT value is 20k. – Waqas Sarwar MVP Jul 1 '16 at 17:54
  • A simple addition: changinghang the LVT mostly has nothing to do with hardware (in the end, sure...) but mostly with the fact that the SQL Server will lock the whole table if you try to access more than 5000 rows. (And this ist the one AllUserData table for all listitems in the whole ContentDB... – Nils Sep 7 '16 at 19:50
0

If your views should return less than 5000 items but displays the threshold error nontheless, make sure the column you are filering on is an indexed column.

Have a look at some of the fine articles on the list view threshold and why you should not modify it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.