0

i'm using custom site column with number type. In my list items i have "MyCustomID" field and i would like to search items by using my custom id number.

I tried to search like this: MyCustomID:1 234 or MyCustomID:1234 and it didn't work.

I checked my Search Schema and i found that i have managed property with mapped crawled property "ows_q_NMBR_MyCustomID". I made it searchable and it didn't help too.

Then i found that i have another available crawled property "ows_MyCustomID". strange? okey i created another managed property and made it searchable. mapped this property with "ows_MyCustomID" crawled property and... it also didn't help.

whenever i changed my search schema i always was doing full crawl.

well, what i'm doing wrong?

0

A crawled property is automatically created for the site column during a crawl. The name of this property is generated by removing spaces from the site column name, and adding a prefix. The prefix that is added varies depending on the site column type. in this example, we get the following crawled properties: ows_q_NMBR_MyCustomID

A managed property is then automatically created, which is mapped to the corresponding crawled property. The name of this property is generated by removing spaces from the site column name, and adding a suffix. The suffix that is added varies depending on the site column type.

ows_MyCustomID

Go to your search service application, metadata properties and crawled properties. Find the crawled property for your number column. Check the option "Include values for this property in the search index". Then do a full crawl.

Check "Searchable" enabled under "Search schema" for particular Managed metadata property

Reference

  • i don't know what it was. but it solved by itself. thanks for describing of search options logic. – Sergey Zykov Jul 8 '16 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.