2

I am trying to move an existing web part from one category to another. I am updating the projects Elements.xml file which tells it what category to be placed in. After making my changes and deploying the project, the web part does not change categories. I have even removed and uninstalled the .wsp file and redeployed my project. Ideas?

EDIT

I have added the Elements.xml file for your view.

<?xml version="1.0" encoding="utf-8"?>
<Elements xmlns="http://schemas.microsoft.com/sharepoint/" >
   <Module Name="(data)" List="113" Url="_catalogs/wp">
      <File Path="(data)\(data)WebPart.webpart" Url="(data)WebPart.webpart" Type="GhostableInLibrary" >
         <Property Name="Group" Value="Custom Web Parts" /> <!--Was "Custom" -->
      </File>
   </Module>
</Elements>

Above, <data> is information I do not wish to display to the public.

  • Remove webpart from http://<servername>/_catalogs/wp/Forms/AllItems.aspx and redeploy your solution. – Dikesh Gandhi Jun 30 '16 at 13:32
1

I think these steps will help to update it.

  • Complete Uninstall the Solution( deactivate, Uninstall and Remove)
  • Reset IIS
  • Reset the SharePoint admin and Timer Service.
  • Deploy new Solution
  • Test now.
  • I completed every step you had mentioned. For some reason the Web Part still will not move to the new category I specified . – IE5Master Jun 30 '16 at 14:43
  • after making the changes to element.xml, did you compile the code and you trying to deploy the new solutions....just want to make sure...Do you have another farm, try their your solution – Waqas Sarwar MVP Jun 30 '16 at 14:49
  • Waqas, I tried the steps again on a different farm and the existing web part still has not moved categories. Maybe when the web part is deployed for the first time it cant change categories after? – IE5Master Jun 30 '16 at 15:59
  • I dont think. i would check the code and see if it is really changing the category. – Waqas Sarwar MVP Jun 30 '16 at 16:02
  • I have added the Elements.xml file for view. – IE5Master Jun 30 '16 at 16:10
0

Turns out it is quite simple. Instead of removing the wsp and reinstalling it, all you need to do is update the Web Part Properties in the Web Parts Gallery.

Follow these steps to change the category of an existing web part.

  • Site Actions (The Gear Icon) > Site Settings
  • Click Web Parts under the Web Designer Galleries.
  • Locate the web part you need to update.
  • Click the edit properties option.
  • Under the Group section, make sure that "Specify your own value" is checked and give it the category you want it to be placed in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.