0

I have created custom newform aspx page binded to newform fromschema as

<Form Type="NewForm" Url="Import.aspx" Path="Import.aspx"  WebPartZoneID="Main" Template="Import.aspx"/>

Added fiels on new aspx page as

<asp:Content ContentPlaceHolderID="PlaceHolderMain" runat="server">


    <div>
        <SharePoint:FieldLabel runat="server" FieldName="Title" ControlMode="New" />
        <SharePoint:FieldDescription runat="server" FieldName="Title" ControlMode="New" />
        <SharePoint:FormField runat="server" FieldName="Title" ControlMode="New" />
    </div>
</asp:Content>

also made page deployement type as ElementFile but on page it only shows filed label but not showing input fields as enter image description here

Suggest some help.Thanks in advance

0

FieldName is the corresponding column name in the list. Do not used display name. Using Display name also works but when you change display name the control won’t render. So I always recommend using columns name for FieldName.

Kindly check Note under the step 4 in below article.

SharePoint List NewForm Customization in SharePoint Hosted App

  • I have use internal name not display name. also followed all the steps mention in the above link but not working – Mrunal Shidurkar Jun 29 '16 at 10:49
  • So silly to ask you but Have you mapped form correctly as mentioned in step 6 as i think it is showing your custom form inplace of DisplayForm so it wont show yo controls? Kindly check it & let me know. – Hardik Jun 29 '16 at 11:02
  • yes I have done that also – Mrunal Shidurkar Jun 29 '16 at 11:10
  • Can you please cross-check using IE DOM that if the controls are on the page or not? – Hardik Jun 29 '16 at 11:12
  • Did you find any resolution? – Hardik Jun 30 '16 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.