0

We have some custom managed properties, linked to additional User Properties in our Office 365 SharePoint User Profiles. If I add a CSWP to a page within our main site collection, I am unable to use these managed properties. If however I do exactly the same query in a CSWP on a page created directly within our Search site collection, it works fine. Any thoughts about where to look? Not sure whether the problem is with the configuration of the search result sources, or the configuration of the Managed Properties.

Thanks for your assistance

  • When you created the MPs did you put them in the PeopleIdx? – Matthew McDermott Jun 28 '16 at 13:59
  • Matt thanks for that we owe you a pint next time you are in the uk . Is this at the Search site ( my preference) or Site collection level. Also can we influence the crawl schedule? – westerdaled Jun 30 '16 at 9:57
  • IIRC it has to be at the SSA/Tenant level. I don't think People Properties work at the SC/Site level. Same for BCS. – Matthew McDermott Jun 30 '16 at 20:04
0

Make sure you put the People Properties in the PeopleIdx. When you create the managed property choose Advanced and change the Index to PeopleIdx.

  • matt . thanks I have done as you say buy w're not seeing the results appear in a Team Site CSWP .. when we add the same CSWp to the search site we do see results . I will ping you an email showing you this and pick up in the morning – westerdaled Jun 30 '16 at 21:22
  • As per Matt's suggestions we've set Tenant->Search-Search Schema to PeopleIdx for relevant Man Props; tried both imported and fresh CSWPs on team sites . Tried FireMarshall:"True" and FireMarshall=1 queries (People Search Service) but only get results back a CSWP in the Search Site. – westerdaled Jul 4 '16 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.