We are neither able to start or reprovision the user profile application after installing the SP-1 on the sharepoint 2010 enterprise environment. Is it a known issue?

  • 1
    Did you install just SP1 or SP1 + the June 2011 CU? There have been reports of similar results. Was the patch(es) fully and successfully installed? – Mike Oryszak Aug 29 '11 at 18:08
  • Are there any correlating events (system log entries, ULS, etc). Always a good review when encountering issues with UPS: harbar.net/articles/sp2010ups2.aspx – Jesus Shelby Aug 29 '11 at 18:23
  • Yes, we have successfully installed the SP1 along with june CU. There are many errors related to FIM and search reported. Is there any work around available? – Karthikeyan Aug 30 '11 at 13:25

I think it is a known side effect when installing June CU.

You can either uninstall .Net 4.0 or force FIM to use .Net Framework v2.0

It is explained here in detail:


  • 1
    This is the correct answer and a known problem! – Wictor Wilen MCA MCM MVP Aug 31 '11 at 11:11
  • at least in my case, it was not the problem.. – Karthikeyan Sep 1 '11 at 4:31

http://sharepointinterface.com/2011/07/05/crashing-owstimer-exe-after-sharepoint-2010-sp1-installation/ I had this problem as well when I installed the service pack in my virtual environment. Although I was able to completely blow it away, I still get encryption errors now after installing the service pack and correcting the errors in this article. It is all related to the Forefront Identity Management services.




Stop the User Profile Synchronization Service
Reset the SyncDB.
Open IIS (inetmgr)
Click on the server name and select Authentication
Selected Anonymous Authentication then choose Edit
Click the specific user, then enter “IUSR”
Add the service account to Local Admin group on the server
Add the service account to all the FIM groups
add the service account to the WSS_WSP and WSS_Admin_WPG group
Perform an IISRESET
Reset SharePoint Timer & SharePoint Admin service
clear the MaData-folder
Ensure that "FIM_SynchronizationService" datarole is present on the sync DB.
Remove all of the FIM certificates are on the server.
Ensure that "Network service account" has full control on - C:\Program Files\Microsoft Office Servers\14.0 folder.
Start the User Profile Synchronization Service
Perform an IISRESET
Verify the C:\Program Files\Microsoft Office Servers\14.0\Synchronization Service\Bin\miiserver.exe.config file
  • not sure if it can be solved without resetting the sync DB. If you have any idea, please help. – Karthikeyan Aug 31 '11 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.