In my SharePoint 2013 environment, the UPS sync service has stopped working and I found out from the ULS logs that and then checked it the database, the farm account when checked under user mapping for the sync database does not show "dbo" under the users tab, but shows "dbo under the default schema whereas it should be showing as dbo in both the columns like all other services.

How would I go about and fix this?

This is the existing situation enter image description here

I want to get here enter image description here

  • Set the account currently holding the dbo User to its own user account and then assign your farm account as dbo user. – Benny Skogberg Jun 23 '16 at 13:32
  • @BennySkogberg Thank you for the reply, but what you are saying is still not clear to me. Would you please elaborate a little about what you want me to do. – CodeAbaddon Jun 23 '16 at 13:42
  • Sure. I've put it as an answer instead and hope it is easier to follow. – Benny Skogberg Jun 23 '16 at 14:12

In your database, one of your accounts (SPInstall, SPSetup, SPService...) is holding the dbo user, with the default schema dbo. Like the following table:

Database    User   Default Schema
========    ====   ==============
Sync_DB     dbo    dbo

Now, there can only be one account holding the dbo user in SQL Server, and you need to find out which user that is. When you do, set that account in the user column as in your list in your question. Like this:

Database    User     Default Schema
========    ====     ==============
Sync_DB     Account  dbo

Then assign the SPFarm account the dbo user with default schema dbo, and you are good to go.

  • Thank you, I deleted the database, deleted the service application and then recreated the service application, which is the UPS app in SharePoint 2013. The issue at hand was resolved by doing so, but he actual issue still remains, which is the UPS Synchronization service is still not working. – CodeAbaddon Jun 23 '16 at 16:39
  • User Profile Service Application - User Profile Incremental Synchronization - This job fails every miniute, because the UPS Sync service just deosnt start. – CodeAbaddon Jun 23 '16 at 16:41

Try an Unprovision/Provision of the SyncDB by running the following script on a SharePoint Server:

Add-PSSnapin *share*

$syncDB =  Get-SPDatabase | ? {$_.Displayname -like "[Your Sync DB]"}

$syncDB.Status = "Offline"

$upsa = Get-SPServiceApplication | ? {$_.TypeName -like "*User Profile Service Application*"}


You will need to grant your farm account permissions on the db again. Afterwards the you should be able to start the Profile Sync Service.


I deleted the SharePoint UPS Service application, along with the Sync database in the database server.

The Social and Profile database stores all the User profile specific data so the Sync database can be deleted and recreated, it doesn't affect the application.

Then I created the UPS service application again which created the sync database with appropriate permissions. Problem Solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.