1

We have cloned our web front end server & SharePoint site stopped working but central admin is working

2
  • 1
    Are you trying to setup a test environment using the clone?
    – Benny Skogberg
    Jun 23, 2016 at 7:27
  • Yes, for testing purpose.
    – Pravin
    Jun 23, 2016 at 8:14

2 Answers 2

2

As of I know sharepoint does not support the cloning once farm is configured due to hard coded references in config db and other issues with config db.

Recommend approach is build a new farm in Dev, take production farm backup and restore in Dev farm with new configuration if within same AD.

2
  • is there a way to change hard coded references in config db. if not then how to setup BCP for SharePoint server.
    – Pravin
    Jun 23, 2016 at 9:59
  • May be you can change it but it is not supported, if you edit dabatabase directly then it will end support agreement with MSFT.
    – Waqas Sarwar MVP
    Jun 23, 2016 at 14:38
2

I have a customer who made a clone of the entire environment to a test environment. This test environment need to be literally separated from production environment since you need to clone the domain controller, the SQL Server and all servers in your production SharePoint Farm. The FQDN of your servers will be the same as in production and it’s very easy to not know where you are, since everything looks and feels the same.

In your case it could be anything from the “app pool account can’t reach the Active Directory and can’t start” to “service ‘Microsoft SharePoint Foundation Web Application’ isn’t started”. Check the most common errors in the databases, IIS and services.msc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.