In my team site, I want to make a new master page, but if I copy seattle.html in sharepoint designer 2013 and paste it (name becomes seattle copy (1).html), it should also create a .master page too for it, that's what happens if I do it on a publishing site. Except here it doesn't create the .master file.

Does anyone know what is wrong?



1 Answer 1


Design Manager (feature which enables HTML to masterpage conversion) is not available in Team Sites as it requires Sharepoint Server Publishing feature to be enabled.

If you want to enable it:

Open Site Settings, Click on "Site collection features" under Site Collection Administration. This will open Site Collection Features page. Search for "SharePoint Server Publishing Infrastructure". Then click on Activate.

Make sure the following are done for the HTML file you upload:

In the Content Type section, select HTML Master Page

In the Compatible UI Version(s) section, select 15.

also, Associated File should be checked.

enter image description here

  • I see "SharePoint Server Publishing Infrastructure" and I enabled it, but I don't see "Design Manager".
    – omega
    Commented Jun 21, 2016 at 19:28
  • It should be available under "Look and Feel" section in Site Settings. Also, activate "Sharepoint Server Publishing" under Site Actions --> Manage Site Features. Commented Jun 21, 2016 at 19:32
  • I did all that. But when I publish and approve it, it still doesn't generate any .master page file. If I open the masterpage file I made in design manager, on the preview page it says "We couldn't find the converted file. After editing and saving your HTML design file, refresh this page. "
    – omega
    Commented Jun 21, 2016 at 19:36
  • Delete that HTML file, create a new copy of the seattle.html and see if that works. It might just be a corrupted copy. Commented Jun 21, 2016 at 19:38
  • Should I make it "Associated File " true for the item properties?
    – omega
    Commented Jun 21, 2016 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.