I recently installed Sharepoint 2010 Foundation on my windows 7 machine, this itself took a while but appears to be ok, ie create sites, libs etc etc.

I'm now trying to create a simple webpart which I can add to my site. I'm using Visual Studio 2010. When I build it I get no error, when I go to try and deploy it I get the below error

Error occurred in deployment step 'Recycle IIS Application Pool': Microsoft .NET Framework 3.5 SP1 is not installed on this system. It is required to perform this operation.

When reading up on the 3.5 SP1 is suppose to come as standard. I've tried installing it to be sure but nothing happens.

Any ideas or tips would be great.


  • have you come across a solution? Dec 19, 2011 at 17:29

3 Answers 3


I had this exact same problem. This sounds like an odd solution, but it worked for me. Go into your Control Panel -> Programs & Features -> Turn Windows Features On or Off and then find the "Microsoft .NET Framework 3.5.1".

Now uncheck "Microsoft .NET Framework 3.5.1", and apply the settings. It should ask you to reboot, so do so. After rebooting, go back in and re-enable this feature.

You should now have a working setup!


Did you try following this guide on MSDN?

  • Been there, done that. Dec 19, 2011 at 17:29

There are a couple of reasons why this occurs...

First make sure the webapp is running the correct .net net, you can either reinstall, repair, or run the iisreg tool. Sometimes you can just delete the web app and create a new one.

Second, make sure you are farm admin and if you are referencing the site URL as local host you'll want to disable the loop back check.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.