2

I have a content hub with a content type based on a Document Set.

If I remove a column or make a change to an existing column from the hub content type and then on CA I run the Content Type Hub job and Content Type Subscriber job, I don't see the changes published.

  • content type syndication hub is enabled on my site content hub site collection
  • Refresh all published content types on next update is checked in my subscriber site collection
  • no error in shown in Content type hub error publishing log

Is there anything else I should check?

3
  • Upto my knowledge you have run the timer jobs required. But I dont understand why it happens so. There were many weird issues like this while using Content type hub. May be this would be one among it. Commented Jun 17, 2016 at 11:41
  • Look in ULS-Log while content types are getting published. You may find an helpful error message there.
    – MHeld
    Commented Jun 17, 2016 at 13:13
  • I see that refresh check box. Do you have to manually hit refresh each time there is an update to the content type? Commented Mar 2, 2021 at 2:39

1 Answer 1

0

May be you might have to check this,

  1. Go to your subscribed site > site settings > content type publishing
  2. Under site collection administration, make sure you have checked "refresh all published content types on next update”

This will update all published content types the next time the content type subscriber timer job runs.

2
  • Check my post. This was already done. Thanks anyway
    – Gyonder
    Commented Jun 17, 2016 at 12:21
  • Sorry i didnt see that. Then as i said before it should be some weird issue. Give some time and run nthe timers again. No other way. Commented Jun 17, 2016 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.